Results 1 to 1 of 1
  1. #1
    Junior Member
    Join Date
    May 2006
    Location
    Fort Collins, CO
    Posts
    3

    Default Installing vim7 on my vps

    I am trying to install vim7 on my vps, and am having difficulties.

    I compile it and try to "make" it and I get an error that starts off here:

    gcc -c -I. -Iproto -DHAVE_CONFIG_H -g -O2 -o objects/buffer.o buffer.c
    In file included from buffer.c:28:
    vim.h:41: parse error before `:'
    In file included from /usr/include/bits/types.h:143,
    from /usr/include/stdio.h:36,
    from os_unix.h:21,
    from vim.h:233,
    from buffer.c:28:

    I checked vim.h and the parse error originates with this section:

    /*
    * Check if configure correcly managed to find sizeof(int). If this failed,
    * it becomes zero. This is likely a problem of not being able to run the
    * test program. Other items from configure may also be wrong then!
    */
    # if (SIZEOF_INT == 0)
    Error: configure did not run properly. Check auto/config.log.
    # endif

    I checked the config.log, there are several "failed programs", and now I'm stumped. What does it mean that "This is likely a problem of not being able to run the test program."? And what does it mean that sizeof(int) is returning 0?

    Or, on the other hand, are there any pre-compiled binaries available that anyone knows of off-hand that would work?

    ** UPDATE: I just noticed another thread that was posted this morning (after I had scoured the forums for any info for weeks ) with info on installing this... I'll check that out.

    Thanks!

    Matt
    Last edited by mrose2n; 05-19-2006 at 10:32 AM.

Similar Threads

  1. Installing mod_rewrite on vps
    By jdegenova in forum Solutions
    Replies: 7
    Last Post: 09-02-2008, 07:56 PM
  2. Howto guide: Installing Mailman
    By nsc in forum CGI Scripts / Perl
    Replies: 6
    Last Post: 02-05-2007, 11:57 PM
  3. Installing Bugzilla on a WestHost VPS
    By sonavor in forum CGI Scripts / Perl
    Replies: 0
    Last Post: 03-28-2006, 11:43 PM
  4. Upgrade SpamAssassin using CPAN?
    By j103c in forum E-mail / FTP Management
    Replies: 54
    Last Post: 06-10-2004, 03:35 PM
  5. Anybody want to try installing openwebmail on my vps ?
    By firebirdfan in forum E-mail / FTP Management
    Replies: 4
    Last Post: 06-07-2004, 11:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •