Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Jan 2006
    Posts
    5

    Default PerlMagick Issues

    Greetings --

    I am having troubles getting a very simple PerlMagick script to execute. After reading other posts on this forum, it does not appear that anyone has been successful with this. I spent some time with Tech Support this evening, and they did knock down some barriers that were mentioned in other posts (like the Magick.so error).

    Here is my simple Perl script:
    Code:
    #!/usr/bin/perl
      use Image::Magick;
    
      my($image, $x);
    
      $image = Image::Magick->new;
      $x = $image->Read('test.jpg');
      $x = $image->Crop(geometry=>'100x100+100+100');
      $x = $image->Write('testNew.jpg');
    It produces the error:
    Code:
    perl: magick/geometry.c:1138: SetGeometry: Assertion `image->signature == 0xabacadabUL' failed.
    Aborted
    If I do a simple 'convert' from the command line, ImageMagick works great. If I go back into my script and comment out the 'Crop' and 'Write' commands, I get no errors - this implies that PerlMagick is installed correctly. However, if either of these commands are in the script, game over - I get the same error produced above. Finally, if I run this on my local machine with my own PerlMagick setup, everything works great - this implies that my script has no errors.

    Has anyone had any success getting PerlMagick to work?

    Thanks in advance for any advice you can offer.

    -- Bob

  2. #2
    Junior Member
    Join Date
    Jan 2006
    Posts
    5

    Default Some Progress ...

    Greetings --

    In case anyone else is reading this thread, I have made some progress on this issue. This strange assertion error occurred because the automatic installation of ImageMagick (and hence PerlMagick) via the Site Manager was *not* functioning properly. WestHost changed their installation script, and the sample scripts above now function properly.

    WH's suggestion after I brought this to their attention (and they made some changes) was to uninstall and reinstall ImageMagick from the Site Manager. This worked on my domain, but I design websites for several of my clients that are hosted by WH, and the ImageMagick installation from their Site Managers simply fails now for their accounts. I think WH may have inadvertantly broken their own installation script.

    Bottom line ... if you run into the error mentioned above or if your Site Manager refuses to re-install ImageMagick, contact Tech Support, and they can fix your domain on a case-by-base basis. It appears that WH does not have a global fix yet.

    Hope this helps somebody out there ...

    -- Bob
    Last edited by Bob; 01-08-2006 at 09:48 PM.

  3. #3
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,720

    Default

    Thanks for the update Bob. I have been haveing some problems with Site Manager recently on some of my accounts. I have a feeling it may be more then just ImageMagick. Hopefully someone from WH will chime in on this and have a comment.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  4. #4

    Default

    One thing to note if the Perl module of ImageMagick is not working is the following:
    $ ldd /usr/local/perl/lib/site_perl/5.8.7/i686-linux/auto/Image/Magick/Magick.so
    /lib/libsphera.so.1 => /lib/libsphera.so.1 (0x4002d000)
    libMagick.so.9 => not found
    libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x40055000)
    libpng.so.2 => /usr/lib/libpng.so.2 (0x40074000)
    libbz2.so.1 => /usr/lib/libbz2.so.1 (0x40098000)
    libxml2.so.2 => /usr/local/lib/libxml2.so.2 (0x400a8000)
    libpthread.so.0 => /usr/lib/libpthread.so.0 (0x401c0000)
    libm.so.6 => /usr/lib/libm.so.6 (0x401f3000)
    libc.so.6 => /usr/lib/libc.so.6 (0x40216000)
    libdl.so.2 => /usr/lib/libdl.so.2 (0x40355000)
    libz.so.1 => /usr/lib/libz.so.1 (0x4035a000)
    libiconv.so.2 => /usr/local/phplibs//lib/libiconv.so.2 (0x40368000)
    /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)

    If you see that the libMagick.so.9 results in a 'not found', it will need to be installed into your /usr/lib folder (which you have access to) for the module to function properly. Tech support is fully able to install this for you, or if you can find a copy yourself, placing it in that directory should enable you to use it. After doing so and running the above command again, you'll see the following:

    $ ldd /usr/local/perl/lib/site_perl/5.8.7/i686-linux/auto/Image/Magick/Magick.so
    <snip>
    libMagick.so.9 => /usr/lib/libMagick.so.9 (0x40050000)
    <snip>

    __________________
    Stephen Hales

    WestHost Support Department
    Phone: 1-800-222-2165
    FAX: 435-755-3449
    http://members.westhost.com

    When you expect more from your web host
    http://www.westhost.com

Similar Threads

  1. secure vs. non-secure issues in Miva5
    By PaulMat in forum Miva Merchant
    Replies: 9
    Last Post: 01-31-2007, 02:33 PM
  2. IMAP issues with Thunderbird
    By cerckert in forum E-mail / FTP Management
    Replies: 3
    Last Post: 11-19-2006, 06:51 PM
  3. Perl obsolete??? security issues???
    By Alejandro in forum CGI Scripts / Perl
    Replies: 4
    Last Post: 11-11-2003, 01:28 PM
  4. Speed Issues
    By gbanse in forum Account Maintenance
    Replies: 0
    Last Post: 09-30-2003, 10:01 AM
  5. SSL Issues, Can Anyone Help?
    By lonestarr in forum General Discussion
    Replies: 5
    Last Post: 09-24-2003, 08:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •