Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    Aug 2004
    Posts
    17

    Default Importing Large DB in PhpAdmin?

    Hello,

    I am unable to import one of my db dumps into PhpAdmin. After taking several minutes to execute the file I finally get the error..."No SQL query!" :?

    The file is not corrupt, but I do believe it may be too large for PhpAdmin to import? (just 11MB...but a serious amount of queries and inserts!)

    Anyone have an idea what I can do to sucessfully import this file?

    Thanks in advance!

  2. #2
    Senior Member Tom Howard's Avatar
    Join Date
    Jul 2003
    Posts
    132

    Default

    Never tried this myself, but here are a couple of guesses....

    Is it timing out?

    What is the max upload size for PHP? Is it less than 11MB? I think mine is set for 2MB right now (the default).

  3. #3
    Junior Member
    Join Date
    Aug 2004
    Posts
    17

    Default

    Found a solution!

    Used the script "bigdump.php" (from hotscripts.com)! Simply ftp your sql file and this script to a directory and --presto-- my file was imported in less than 30 sec! (11 mb. sql file!)

    Incredible script --I recommend it to anyone here trying to import a large db via phpmyadmin.

  4. #4
    Senior Member jalal's Avatar
    Join Date
    May 2003
    Location
    Germany
    Posts
    1,377

    Default

    It's also possible to ftp the SQL file up to the server and import it via the shell (which is, I guess, what bigdump.php is doing behind the scenes).
    Glad it worked out for ya.

  5. #5

    Default

    I am trying the bigdump.php script, but for the life of me, I can't figure out how the username & password should be configured.

    It is my understanding that they should be the same as my account login, but those are not working.

    Should I place this script in a particular folder?

  6. #6
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,720

    Default

    Username = root

    Give that a try and see if it helps.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  7. #7

    Default

    Thank you! It seems to have worked perfectly.

    Now all I have to do is play with my IPB settings (probably the path to 'html' directory) to get my board up and working again.

Similar Threads

  1. Large Mailbox Archival Warning
    By jsimmons in forum E-mail / FTP Management
    Replies: 8
    Last Post: 11-12-2007, 02:41 PM
  2. Large Mailbox
    By sigep416 in forum E-mail / FTP Management
    Replies: 1
    Last Post: 08-07-2007, 03:33 AM
  3. Problems Uploading Large File w/ PHP
    By bpk in forum General Discussion
    Replies: 1
    Last Post: 01-31-2006, 01:25 PM
  4. Moving a Large Database
    By dvduval in forum PHP / MySQL
    Replies: 0
    Last Post: 06-27-2005, 09:42 AM
  5. Large File Uploads
    By lonestarr in forum PHP / MySQL
    Replies: 1
    Last Post: 06-16-2005, 01:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •