Results 1 to 10 of 10

Thread: root email

  1. #1
    Senior Member
    Join Date
    Sep 2003
    Location
    Sun & More Sun, Florida
    Posts
    196

    Default root email

    WildJoker:

    Please elaborate - what does this mean?

    Am I getting returned mail - and I just do not know from whom?

    Charlie

  2. #2
    Member WestHost - MMellor's Avatar
    Join Date
    Mar 2004
    Posts
    206

    Default

    Hey Charlie,
    When you say that you are getting returned mail. What do you mean by that? Are messages that you are sending people getting sent back to you that you feel are legitimate? If you give us some more details on this we will be able to figure it out for you.
    Michael L. Mellor
    WestHost Support Department
    Phone: 1-800-222-2165
    FAX: 435-755-3449
    http://members.westhost.com

  3. #3
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,720

    Default

    Mike, He was talking about this thread http://forums.westhost.com/phpBB2/viewtopic.php?t=1786

    Charlie,

    I am not sure about all the specifics but others have had the problem when they send out mailing via a script. I think that since the mailing is sent by root that is not really a user that when an email is not accepted by the mail server where it was sent it trys to send it back to root@yourdomain.com and you end up with it kind of looping and getting to you as a postmaster notification. The process I gave you was one that WestHost had suggested would fix the problem. Once you do that root then shows up as an aliase in your site manager. I think that if you try to set it up via your site manager you get an error which is why the manual set up was suggested.

    I think the original thread on this is still here. If I can find it I'll come back and post a link to it here so you can follow the whole thing.

    I may be wrong about this in your case but it sure sounds like the other cases.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  4. #4
    Senior Member
    Join Date
    Sep 2003
    Location
    Sun & More Sun, Florida
    Posts
    196

    Default postmaster mail

    Sorry about that.

    I made a mistake and clicked "new topic" instead of "post reply".

    See thread http://forums.westhost.com/phpBB2/viewtopic.php?t=1786 for the orignal post.

    Let me restate the problem with some more details.

    I did a small mailing about 250 emails. I was using dada mail formerly known as mojo mail.

    I got a bunch of replies - about 25 - from "Mail Delivery Subsystem" subject "Postmaster Notify - see transcript for details".

    I am assuming these are returned emails. Correct?

    Several have two attachments. If there are two attachments then in one of the attachments there is shown the bad email address. Which is what I need to fix the list.

    But most have only one attachment. The file name is ATT00012X.dat. And nowhere in the body of the email or in the attachment is the bad email address.

    Here is the body of the postmaster email:


    The original message was received at Sat, 10 Apr 2004 09:09:21 -0600
    from localhost
    with id i3AF9LW11494

    ----- The following addresses had permanent fatal errors -----
    root
    (reason: permission denied)

    ----- Transcript of session follows -----
    procmail: Insufficient privileges
    550 5.0.0 root... Insufficient permission



    --------------------------------------------------------------------------------


    Return-Path: <MAILER-DAEMON>
    Received: from localhost (localhost)
    by calvinstudiessociety.org (8.11.6/8.11.6) id i3AF9LW11494;
    Sat, 10 Apr 2004 09:09:21 -0600
    Date: Sat, 10 Apr 2004 09:09:21 -0600
    From: Mail Delivery Subsystem <MAILER-DAEMON>
    Message-Id: <200404101509.i3AF9LW11494@calvinstudiessociety .org>
    To: root
    MIME-Version: 1.0
    Content-Type: multipart/report; report-type=delivery-status;
    boundary="i3AF9LW11494.1081609761/calvinstudiessociety.org"
    Subject: Returned mail: see transcript for details
    Auto-Submitted: auto-generated (failure)

    So I guess my final questions are: did these emails go out and get returned? Why can't I see the intended email address?

    Thanks

    Charlie

  5. #5
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,720

    Default

    Pretty sure this is the root problem I mentioned. Wish someone else would chime in. Each of these should have an attachment with them that contains the original bad address in it. That was the problem with this before. Since the original mail was returned to root that failed because it was not recongized by your mail set up as a user then I think your system sent it on to the postmaster address as an attachment with the message you posted. Made it hard to see the original email since it was an attachment and then you have to open up each attachment to get the email address that was bad.

    You said that most of them did not have the attachment wich I am not sure about. Are there any changes you have made to your mail system that may have affected that? I have recieved returns before with the same situation that had just the ATT... file so maybe it has to do with how the mail server you where sending to returns the mail.

    Have you tried the root fix I mentioned. Of course that won't show as a fix till the next time you send out a mailing.

    It may be that there is something you can do to dada mail that whould add to the header of the email to tell it to return mail to the postmaster accouunt instead of the root user. I think the other mail servers are doing that because they see root as the sending address if you can figure out how to modify that part of the mails sent them maybe that would help also. I just don't know enough about dada mail or even modifying the email header to help you on that one. I think there is a difference between the header and the envelope of the email and maybe the envelope is the part that you need to work with.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  6. #6
    Senior Member
    Join Date
    Sep 2003
    Location
    Sun & More Sun, Florida
    Posts
    196

    Default Postmaster mail

    Wild Joker - thank you for responding to me several times on this. I'm going to take a look at doing some of your suggestions in your various posts. Charlie

  7. #7
    Member WestHost - MMellor's Avatar
    Join Date
    Mar 2004
    Posts
    206

    Default

    Hey Charlie,
    What is your domain? I can take a look around on our end and see if anything is going on that we need to fix. Keep us posted on your progress.
    Michael L. Mellor
    WestHost Support Department
    Phone: 1-800-222-2165
    FAX: 435-755-3449
    http://members.westhost.com

  8. #8
    Senior Member
    Join Date
    Sep 2003
    Location
    Sun & More Sun, Florida
    Posts
    196

    Default postmaster mail

    Mike:

    it is calvinstudiessociety.org.

    Thanks

    Charlie

  9. #9
    Senior Member torrin's Avatar
    Join Date
    May 2003
    Location
    Vista, CA
    Posts
    534

    Default

    Hmmm . . . that's interesting.

    I thought that all E-mail to your domain was set up to go to the catch all when the to(from in this case) address doesn't exist. Is this a new problem in 2.0? Or is this just a problem because this a bounce and the from address is a non-existent user?

    Oh, and by the way, some westhost moderator should just merge this topic with the other one.

  10. #10
    Member WestHost - MMellor's Avatar
    Join Date
    Mar 2004
    Posts
    206

    Default

    Hello Torrin,

    The catch-all with get erroneous emails sent to a domain when it is setup. If it is not setup within your Site Manager then it will not be enabled. Let us know if you have any other questions.
    Michael L. Mellor
    WestHost Support Department
    Phone: 1-800-222-2165
    FAX: 435-755-3449
    http://members.westhost.com

Similar Threads

  1. unable to send email to extrenal email address
    By <-- R O B --> in forum E-mail / FTP Management
    Replies: 1
    Last Post: 01-15-2004, 04:16 AM
  2. Delete or disable domain@domain.com POP account?
    By maida in forum E-mail / FTP Management
    Replies: 24
    Last Post: 10-29-2003, 01:24 PM
  3. Lots of directories in /proc...?
    By humuhumu in forum General Discussion
    Replies: 7
    Last Post: 10-09-2003, 05:31 PM
  4. Email from WHMLM being bounced to root
    By DylanW in forum E-mail / FTP Management
    Replies: 0
    Last Post: 10-01-2003, 03:32 PM
  5. email here today, gone tomorrow
    By Mafdet in forum E-mail / FTP Management
    Replies: 6
    Last Post: 09-06-2003, 02:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •