Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    May 2003
    Location
    Athens, Tennessee
    Posts
    13

    Default MojoMail subscription form gives 500 error

    I was just informed by a visitor today that our newsletter subscription form was giving him a server error. I double checked it, and sure enough, it's not working, although the rest of the Mojo Mail system seems to work fine (I can log into admin, etc.) I tried reinstalling it through the control panel, but it didn't fix anything.

    Before I went digging into code I wanted to see if there was already a solution.

    Here's the errors listed in the log file:
    Code:
    Use of uninitialized value in numeric eq (==) at /MOJO/Mail.pm line 626.
    Cannot create object, initialization error: Invalid address: Shavonne.com Updates <webmaster@shavonne.com> at /MOJO/Mail.pm line 633.
    [Tue Mar  2 08:35:03 2004] [error] [client 68.155.8.43] Premature end of script headers: /var/www/cgi-bin/mojo/mojo.cgi

  2. #2
    Junior Member
    Join Date
    May 2003
    Location
    Athens, Tennessee
    Posts
    13

    Default

    Nevermind... apparently I had configured the MojoMail SMTP settings wrong. Oops. :?

Similar Threads

  1. Form Mail config error
    By walt in forum CGI Scripts / Perl
    Replies: 16
    Last Post: 02-15-2005, 04:20 PM
  2. Error in recipient of form mail
    By rameygifts in forum CGI Scripts / Perl
    Replies: 3
    Last Post: 10-16-2004, 03:06 PM
  3. .htaccess and 500 Internal Server Error
    By dpfaigin in forum CGI Scripts / Perl
    Replies: 16
    Last Post: 06-21-2004, 06:37 AM
  4. Formmail 500 error fix
    By ponyboy in forum CGI Scripts / Perl
    Replies: 5
    Last Post: 12-07-2003, 02:05 PM
  5. 500 Internal Server Error / missing.html file problem
    By samp in forum General Discussion
    Replies: 3
    Last Post: 06-19-2003, 01:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •