Do you have this installed on your servers?

I get errors if I uncomment this in my script

#use Image::Magick; $magick = 1; # Uncomment if using ImageMagick.