Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Oct 2003
    Location
    Carmel, NY (USA)
    Posts
    15

    Default Error message running CPAN

    I have been receiving the following error message when I run CPAN. The log of the session follows. I tried to install the module that was indicated in the error message, but that failed as the log shows. I would appreciate any help possible.

    Thanks!

    Jerry

    [seibercom][~]$ perl -MCPAN -e shell

    cpan shell -- CPAN exploration and modules installation (v1.76)
    ReadLine support enabled

    Can't ioctl TIOCGETP: Invalid argument
    Consider installing Term::ReadKey from CPAN site nearby
    at http://www.perl.com/CPAN
    Or use
    perl -MCPAN -e shell
    to reach CPAN. Falling back to 'stty'.
    If you do not want to see this warning, set PERL_READLINE_NOWARN
    in your environment.
    Can't exec "stty": No such file or directory at /usr/local/perl/lib/site_perl/5.6.0/Term/ReadLine/readline.pm line 1546.
    Cannot call `stty': No such file or directory at /usr/local/perl/lib/site_perl/5.6.0/Term/ReadLine/readline.pm line 1546.
    cpan> get Term::ReadKey
    Going to read /home/seibercom/.cpan/sources/authors/01mailrc.txt.gz
    Going to read /home/seibercom/.cpan/sources/modules/02packages.details.txt.gz
    Database was generated on Wed, 29 Oct 2003 10:47:14 GMT
    CPAN: HTTP:ate loaded ok
    Going to read /home/seibercom/.cpan/sources/modules/03modlist.data.gz
    Running get for module Term::ReadKey
    CPAN: Digest::MD5 loaded ok
    Checksum for /home/seibercom/.cpan/sources/authors/id/J/JS/JSTOWE/TermReadKey-2.21.tar.gz ok
    Scanning cache /home/seibercom/.cpan/build for sizes
    TermReadKey-2.21/
    TermReadKey-2.21/genchars.pl
    TermReadKey-2.21/README
    TermReadKey-2.21/MANIFEST
    TermReadKey-2.21/test.pl
    TermReadKey-2.21/ReadKey.pm
    TermReadKey-2.21/Makefile.PL
    TermReadKey-2.21/Configure.pm
    TermReadKey-2.21/ppport.h
    TermReadKey-2.21/ReadKey.xs
    Removing previously used /home/seibercom/.cpan/build/TermReadKey-2.21

    cpan> install Term::ReadKey
    Running install for module Term::ReadKey
    Running make for J/JS/JSTOWE/TermReadKey-2.21.tar.gz
    Is already unwrapped into directory /home/seibercom/.cpan/build/TermReadKey-2.21

    CPAN.pm: Going to build J/JS/JSTOWE/TermReadKey-2.21.tar.gz

    Checking if your kit is complete...
    Looks good
    Writing Makefile for Term::ReadKey
    mkdir blib
    mkdir blib/lib
    mkdir blib/lib/Term
    mkdir blib/arch
    mkdir blib/arch/auto
    mkdir blib/arch/auto/Term
    mkdir blib/arch/auto/Term/ReadKey
    mkdir blib/lib/auto
    mkdir blib/lib/auto/Term
    mkdir blib/lib/auto/Term/ReadKey
    mkdir blib/man3
    cp ReadKey.pm blib/lib/Term/ReadKey.pm
    AutoSplitting blib/lib/Term/ReadKey.pm (blib/lib/auto/Term/ReadKey)
    /bin/perl -I/usr/local/perl/lib/5.6.0 genchars.pl

    Writing termio/termios section of cchars.h... Done.
    Checking for sgtty...
    Sgtty NOT found.
    Writing sgtty section of cchars.h... Done.
    /bin/perl -I/usr/local/perl/lib/5.6.0/i686-linux -I/usr/local/perl/lib/5.6.0 /usr/local/perl/lib/5.6.0/ExtUtils/xsubpp -noprototypes -typemap /usr/local/perl/lib/5.6.0/ExtUtils/typemap ReadKey.xs > ReadKey.xsc && mv ReadKey.xsc ReadKey.c
    gcc -c -fno-strict-aliasing -I/usr/local/include -O2 -DVERSION=\"2.21\" -DXS_VERSION=\"2.21\" -fpic -I/usr/local/perl/lib/5.6.0/i686-linux/CORE ReadKey.c
    make: gcc: Command not found
    make: *** [ReadKey.o] Error 127
    /bin/make -- NOT OK
    Running make test
    Can't test without successful make
    Running make install
    make had returned bad status, install seems impossible

    cpan>

  2. #2
    Senior Member jalal's Avatar
    Join Date
    May 2003
    Location
    Germany
    Posts
    1,377

    Default

    You need to install gcc.

    Site Manager/Tools/Development.

  3. #3
    Junior Member
    Join Date
    Oct 2003
    Location
    Carmel, NY (USA)
    Posts
    15

    Default

    Quote Originally Posted by jalal
    You need to install gcc.

    Site Manager/Tools/Development.
    Thanks for the help!

    Jerry

  4. #4

    Default

    Quote Originally Posted by jalal View Post
    You need to install gcc.

    Site Manager/Tools/Development.
    Thanks a lot man...was really stuck at this part.

  5. #5
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,721

    Default

    Set permissions to 755 on your script.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

Similar Threads

  1. Installing Perl GD module with CPAN
    By sonavor in forum CGI Scripts / Perl
    Replies: 15
    Last Post: 10-12-2006, 03:12 AM
  2. Installing Perl modules with CPAN
    By jalal in forum CGI Scripts / Perl
    Replies: 19
    Last Post: 11-03-2005, 10:02 AM
  3. Replies: 10
    Last Post: 07-06-2005, 10:53 AM
  4. Problems updating CPAN Data::Dumper
    By bphillips in forum CGI Scripts / Perl
    Replies: 0
    Last Post: 06-22-2005, 10:21 PM
  5. Spamassassin upgrade isn't working - part 2
    By bstreet in forum E-mail / FTP Management
    Replies: 2
    Last Post: 06-10-2005, 02:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •