Results 1 to 4 of 4
  1. #1

    Default SMTP settings for Joomla under the new cpanel hosting (With office 365)

    We had an old cpanel account with a .com address. We purchased a new cpanel account for a .edu address. Note that we are using office 365 for our email with the appropriate MX records set up already.

    I backed up the old joomla site from the .com and restored it to the .edu/cpanel hosting. That went fairly well.

    However, I am having a heck of a time getting the forms mailer to work. Joomla has a setup page where you can set

    - Mailer -- PHP Mail, Sendmail, SMTP
    - From email
    - from name
    - Sendmail path - The sendmail path that existed under site manager does not appear to exist under cpanel. Is sendmail available under cpanel?
    - SMTP Authentication yes/no
    - SMTP Security - none, ttl, ssl
    - smtp port
    - smtp host
    - Smtp username


    - I realize I'm not an 'out of the box' joomla install on westhost cpanel. However, things should be pretty much the same Suppose I set up an 'out of the box' install of joomla from a westhost cpanel hosting account:

    - Which of the three would I use , sendmail, php mail or smtp
    - Will this work with the office 365 mx and txt entries being present
    - IF smtp should work, what would the settings be?



    I've tried various combinations of user accounts/credentials for smtp and keep getting a 'the page at www.bcsbc.edu says undefined'.

    I'd appreciate any help. Also, if anyone has a php script handy where I could test the smtp functionaity outside of joomla, that might help.

    thanks

    chris

  2. #2
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,721

    Default

    If you log in to cPanel for the domain you should see the path for sendmail in the left column. Should be /usr/sbin/sendmail

    To double check your other setting click on Email Accounts then look for the email address you are trying to set up in the list of emails. Then in the far right column you should see a More drop down menu. Choose configure email client from the menu and you should see your settings for that email on the next page. I personally would use the secure settings. Server = smtp host
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  3. #3

    Default Got it working

    I was looking in the wrong direction. I use Fabrik to create my forms. Fabrik has a database connection that needed to be updated when I copied the site over. Even at that, it didn't seem to work until I remoted into another system and connected from there. Apparently there is some caching going on at the server and/or browser level that I couldn't clear.

    Once I cleared up the connection issue, the mail started working via sendmail. I agree that smtp is more secure. ONce things settle down, I"ll move over to SMTP.

    Again, when I copied the site, the sendmail parameters were correct. However, I had to fix the connection details for fabrik because the failure to connect to the database was, of course, precluding sending emails.

    thanks

    chris

  4. #4
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,721

    Default

    Glad you got it worked out. It can be so hard to track down issues. Some times the symptom is not the actual cause so to speak. I know I've spent hours looking in the wrong place only to find out I left of a single character in another place.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •