Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    Mar 2012

    Default access files above your folder

    Why is it that bots (and others) can access files above your folder? Some webmasters are recommending changing hosts if your host allows this. And this happens on Westhost.
    see this discussion-

  2. #2
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Kansas City Mo


    You are still on a Site Manager account I assume since this does not happen with the newer cPanel sites. Pretty easy to "fix" if you want to. Edit /etc/httpd/conf/httpd.conf

    Alias /icons/ "/var/www/icons/"
        <Directory "/var/www/icons">
            Options MultiViews
            AllowOverride None
            Order allow,deny
            Allow from all
    NOTE: Don't remove the cgi-bin alias right below that or any cgi/pearl scripts you use won't work.

    Don't forget to restart your account after you make changes.

    This was a default set up by the installation of Apache. Really no harm in it that I know of. I actually used it on one site I created because it had icons in it I wanted to use. If you are not going to use them you might as well get rid of them and the directory also.
    Please remember your charity of choice:

    Handy Links: | Plain Text Editors: EditPlus | Crimson

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts