Results 1 to 5 of 5
  1. #1

    Default php 5.2.8 & 5.3.8 installed. Unins 5.2.8 - site crashes, site manager erratic

    I had an install of Joomla 2.5.9. Just upgraded that to 2.5.11

    I was having some problems and checked the php installs on my host. I am still on the old site manager. I noticed that there was a PHP 5.2.8 and php 5.3.8. I uninstalled the 5.2.8. version

    Right after that, clicking on any links in the front or back end of joomla would result in a download, not going to the page. The site manager was also whacky. If I went to phpmyadmin, I got a 404 trying to login.

    Question - Has anyone else had trouble with a host with two versions of PHP and deleting the old version??

    Westhost support restored a backup from yesterday's snapshot.

    The problem is that I would like to remove the 5.2.8 php version . I can see even more problems as we go forward.

    I'd appreciate any ideas..

    thanks

    chris

  2. #2
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,720

    Default

    So you had both PHP 5.2.8 and 5.3.8 installed on the account? I didn't think that Site Manager allowed for that. Log in to your site via FTP and confirm that there are indeed two versions of PHP installed. Go to /usr/local and see if there are the two versions. You should see normally two php directories listed there php and php-{version} the first is actually just a symbolic link to the other. If you see only the two then you actually have only one version of PHP installed, SM just thinks you have the other installed. If there are two version then I would simply contact support and have them take care of it.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  3. #3

    Default

    @WJD - Yes, there were two versions showing in SM. There were folders for php and php.version for both versions.

    That should not have happened and i"m not sure how long it has been that way. When I went to uninstall 5.2.8, it crashed things for good.

    The restores from WH didn't work. Scott and Matthew were very helpful throughout. This morning, I checked and SM was showing no installs of PHP. I checked with support and renamed the php folders, then I reinstalled 5.3.8. Seems to be working now.

    I have checked some of the site out and it seems to be OK. I'll know for sure by tomorrow.

    chris

  4. #4
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,720

    Default

    It sounds like you most likely have it sorted. If your wordpress pages are showing up that at the very least means that the new install of PHP 5.3.8 is working. You might want to keep working with support though because the most recent version of PHP available in Site Manager should be PHP 5.3.24. In fact it is odd that you even have 5.3.8 available to you since on the accounts I have in Site Manager do not have that as an option. Now if you have a reseller account then that could be the reason since you would need to log in to Reseller Manager and update the packages for your accounts under the reseller account.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  5. #5

    Default

    @WJD

    Thanks for the information. I just double checked and 5.3.8 is the latest version of PHP available. I will follow up on that.

    The site is a Joomla site and is running which means that the PHP is working as you said.

    thanks again for the info.

    chris

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •