Results 1 to 3 of 3
  1. #1

    Default Allowed memory size?

    My Wordpress blog had been working perfectly, until recently. This is a WH4.0 site.
    I have made no changes or updates to it. Now it gives this error-

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 23040 bytes) in /home/mysite/public_html/forum/wp-includes/post.php on line 286

    Any idea why it's doing that? Has WH changed something?
    You can discover more about a person in an hour of play than in a year of conversation.

  2. #2
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Kansas City Mo


    Could be the server that this account is on is having some resource issues and they are trying to sort them out. Have you tried contacting WestHost about this? I think that normally they set the limit to 128M but it looks like on this server it may be set at 8M. You can override the php.ini file using this method. In your case you are looking for an entry around line 233 and it might look like this: memory_limit = 8M You should be able to change that back to memory_limit = 128M. I would still contact WestHost and ask them about this though.
    Please remember your charity of choice:

    Handy Links: | Plain Text Editors: EditPlus | Crimson

  3. #3


    Some great advice from wildjoker, that page explains the process to get a local php.ini file very well. That should allow you to set the memory limit higher for your specific account. Also, feel free to contact us via a ticket or chats/phones if you need further help setting that up.
    Nathan Collings
    Level 2 Technical Support Rep

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts