Results 1 to 4 of 4

Thread: smtp and ssl

  1. #1
    Junior Member
    Join Date
    Jan 2005
    Posts
    21

    Default smtp and ssl

    I have a client that sends me a few daily reports from their mainframe using SMTP on port 2525. The want to start sending the reports using SSL on port 465 (I think that was the port number). Does WH3.0 support that option?
    Tony T

  2. #2
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,720

    Default

    I don't think that the older Site Manager accounts support this. At least not by default. I would check with support directly though to make sure. I know that on the new cPanel accounts you have the option of connecting to the mail server securely.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  3. #3

    Default

    Yes, I want to do something similar.
    Maria

  4. #4
    Senior Member rolling's Avatar
    Join Date
    May 2004
    Location
    Different day, different place
    Posts
    486

    Default

    I've been looking into this issue as well.

    As a minimum, you need to reconfigure sendmail (/etc/mail/sendmail.mc) and edit your IMAP/POP server configuration (/usr/local/dovecot/etc/dovecot.conf for Dovecot) to let them know where the certificates, keys and authority chains are. I obtained free SSL certificates from StartSSL.com

    This excellent article (click here) explains how to install the Mozilla trusted Root Certificate Authorities for your Openssl if you need them. The scripts need some modification to run on Westhost, but remember that it is up to the client (ie email program) to verify your certificate, not your mailserver. You only need to import these certificates if you are going to use client certificates to login.

    There are some issues with the Westhost build of sendmail. It does not appear to support SASL2, so you cannot use the MD5 methods for encrypting your password and I cannot seem to enable ports 465 or 587 (although I would swear they were working at one stage). However, I have been able to use TLS/SSL over STARTLS using port 2525.

    Since this is not a standard port, I recommend setting up a special file called config-v1.1.xml in /var/www/html/.well-known/autoconfig/mail which will let Thunderbird, Outlook etc configure the email client automatically. You can also setup a subdomain autoconfig.example.com to point to this file. Full details are given in this Mozilla article: https://developer.mozilla.org/en-US/...oconfiguration. A sample illustrating the format for config-v1.1.xml is available if you follow the last link on the page.

    I have started writing up the changes I made, but it could be a while before I finish.


    ==
    Addendum:
    I used to be able to connect to port 587 as confirmed in this thread, but Westhost support ran a script when troubleshooting the SASL2 issue and now 587 doesn't work anymore. You may be lucky.
    Last edited by rolling; 11-13-2012 at 01:35 PM. Reason: Port 587
    Richard

    I have jotted down some of my meddlings at http://www.rollingr.net/wordpress
    Click here for a full list of formatting codes for this forum

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •