Results 1 to 3 of 3
  1. #1
    Moderator ifurniss's Avatar
    Join Date
    Oct 2009
    Location
    Utah
    Posts
    47

    Default cPanel Cloud Reseller hostname settings

    If you have a Cloud Reseller account and you are getting e-mails from the cPanel with info similar to:

    The hostname (domainserver.) resolves to . It should resolve to
    123.45.67.890. Please be sure to correct /etc/hosts as well as the
    'A' entry in zone file for the domain.

    Some are all of these problems can be caused by /etc/resolv.conf
    being setup incorrectly. Please check this file if you believe
    everything else is correct.

    You may be able to automatically correct this problem by using the
    'Add an A entry for your hostname' option under 'Dns Functions' in
    your Web Host Manager.
    To fix your hostname you'll want to perform the following:
    1. Login to WHM, aka WebHost Manager,

    2. Navigate to Change Hostname on the left column [use the search box in the upper left if needed],

    3. Change your hostname to something like vps.domain.com [replacing domain.com with a valid domain on your account].
    - If your hostname is already taken, get creative and use something like server.domain.com or cloud.domain.com. The only restrictions are that it needs to not already exist in the account, and that it be a valid domain. -
    4. Click the button to Add A Record as the final step.
    Isaac Furniss
    Technical Support Team Manager
    Contact Support: E-mail | Live Chat | Twitter

    http://www.westhost.com/

  2. #2
    Moderator ifurniss's Avatar
    Join Date
    Oct 2009
    Location
    Utah
    Posts
    47

    Default

    I've seen a few instances where the hostname has been changed and two entries exist in the /etc/hosts file. If this is the case, remove the line with your account's IP from the file and re-create the hostname in WHM.

    You can check the hostname when logged in via SSH as root with:
    hostname -i
    You can also manually run the check on the hostname with:
    /scripts/ipcheck
    Isaac Furniss
    Technical Support Team Manager
    Contact Support: E-mail | Live Chat | Twitter

    http://www.westhost.com/

  3. #3

    Default

    If the above solutions are taken, but you still receive those emails, it's likely an issue with the resolv.conf file. If the system can't correctly query the nameservers, then it won't be able to tell that the A record has been correctly added. That doesn't happen very often, but if it does it's likely an extra unneeded line in the resolv.conf that's causing the issue. If you do continue to see issues, I would recommend submitting a ticket so that support can take a look into the resolv.conf file.
    Nathan Collings
    Level 2 Technical Support Rep

    http://www.westhost.com/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •