Results 1 to 8 of 8
  1. #1
    Member
    Join Date
    Sep 2003
    Location
    Spokane WA
    Posts
    38

    Default Need to change http config

    I've worked with htaccess but not a config file. I have a secondary domain set up and need to change the http config file to allow htaccess directives for that domain. I found the httpp config file, and the host told me what section needs to change but didn't say what to put in there (and they won't fix it) and I've surfed the net and can't find it there either. Here is the section that needs to change:

    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory>

    do I add: allow /var/www/domain.com on 3rd line above, or something else?

    thanks,
    Lori

  2. #2
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,721

    Default

    This is how I do it for a West Host 3.0 account. http://wildjokerdesign.net/faq/how-d...condary-domain It sounds like this might be an account with another hosting company but it should be similar.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  3. #3
    Member
    Join Date
    Sep 2003
    Location
    Spokane WA
    Posts
    38

    Default

    Hi WildJoker,

    The host I was referring to is indeed WestHost. They told me they don't work with htaccess, which I already knew, however, it seems to me when a 2nd domain is set up on the same account THEY should set up httpconfig themselves so htaccess will work on that new account like it does on the main account. The same thing happened with that other post I submitted last month trying to get formmail to work on a brand new site where formmail was already installed -- they didn't put in the correct path to formmail/sendmai. I also haven't been getting notices re replys in this forum so I just changed it to my main email this morning and then I couldn't log into this forum to reply to this post morning. Why? Because they never posted a message saying I had to confirm the change via my email account. A total lack of info for all 3 incidents. I have about 30 clients hosted on Westhost but I"m ready to look for another and move them all. This was a good host up till this last year or so.

    PS. It took me so long to type this up I got logged out and then when I logged in again It reverted to a blank page. THANK GOD I copied that post before I hit submit (been there/done that).

    (Rant off /)

    At least we have you to rely on to help with these problems

    Back to this current problem. I read your article on your website (BTW, I used almost the same exact words when searching for help yesterday but never saw your article). I couldn't find the piece of code in httpconfig exactly as you indicated. Following is what I found (notice there is no path to the secondary domain like you mentioned should be in there so I'm not sure what to do here.

    <Directory />
    Options FollowSymLinks
    AllowOverride All
    </Directory>
    <Directory "/var/www/html">
    Options FollowSymLinks MultiViews Includes ExecCGI
    AddHandler cgi-script .cgi .pl .py .sh
    AllowOverride All
    Order allow,deny
    Allow from all
    </Directory>
    <Directory /usr/share/doc>
    order deny,allow
    deny from all
    allow from localhost .localdomain
    Options Indexes FollowSymLinks
    </Directory>
    <Directory "/www/htdocs">
    Options FollowSymLinks MultiViews Includes ExecCGI
    </Directory>
    Lori

  4. #4
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,721

    Default

    Lori,
    The area I am talking about should be at the bottom of the httpd.conf file. What you have posted above would be further up in the file as a rule. Do you see an entry for the subdomain at the bottom of the page?

    You are looking for something that looks like this:
    Code:
    <VirtualHost *:80>
      ServerName domain.com
      ServerAlias www.domain.com
      DocumentRoot /var/www/domain.com
      </VirtualHost>
    And you would alter it to this:
    Code:
    <VirtualHost *:80>
      ServerName domain.com
      ServerAlias www.domain.com
      DocumentRoot /var/www/domain.com
      <Directory "/var/www/domain.com">
        Options FollowSymLinks MultiViews Includes ExecCGI
        AddHandler cgi-script .cgi .pl .py .sh
        AllowOverride All
        Order allow,deny
        Allow from all
      </Directory>
    </VirtualHost>
    So you are looking for the VirtualHost tag for the secondary domain, and adding the Directory tag inside of that. Don't forget that you have to restart Apache either via an SSH session or via the Sitemanager and the Restart Account link.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  5. #5
    Member
    Join Date
    Sep 2003
    Location
    Spokane WA
    Posts
    38

    Default

    Hi WildJoker,

    I found the section of code you mentioned (the Westhost Tech person had pointed me to the one for the domain and not the 2nd domain).
    Thanks for your help.

    I changed the code as specified (adding the domain name) and went to site manager and clicked the "Restart Account Link" and nothing happened. I checked both the domain and 2nd domain and neither went down and the includes are not working on the 2nd domain.

    Do you think tech support will help with this?
    Lori

  6. #6

    Default

    Lori,

    I'm sorry to hear about the issues you've run into while trying to get this to work. This is definitely something Technical Support can help you with and I apologize we were not helpful to you when you contacted us previously. Feel free to call in to 800-222-2165 anytime or come into chat at http://www.westhost.com/chat/ and we can help you get this working.
    Sincerely,

    Dustin Olson
    Technical Support Manager
    WestHost

    Believe in Better Hosting
    http://www.westhost.com/

  7. #7
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,721

    Default

    Cool! Now that you have done some work I bet if you contact tech support they can get it worked out. They may have misunderstood what you wanted to do. I bet they thought that you wanted help on the .htaccess file itself. That would be outside the scope of what they do but getting a .htaccess file to be included should be something they can do. It thought it was kind of odd when you said they could not help you. You can always reference this post when you talk to them. That well help them to understand maybe what you have done so far and if I have perhaps mislead you on some step.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  8. #8
    Member
    Join Date
    Sep 2003
    Location
    Spokane WA
    Posts
    38

    Default

    Thanks Dolson, I have submitted another support ticket and I referenced this thread. Calling would take too long to explain all this.

    Wild Joker -- yes it seems to me like they should have set this up too, and they knew it was the config file that needed to be changed right from the start. May have been a new tech person as I haven't seen his name before.
    Lori

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •