Results 1 to 2 of 2
  1. #1
    Junior Member
    Join Date
    May 2009
    Location
    Louisville, KY
    Posts
    9

    Default ejabberd install error

    I am in the process of installing ejabberd on my VPS. I have been successful so far, however there's an error related to Erlang. When I run this command:

    Code:
    ./ejabberdctl live
    I get this error:

    Code:
    {error_logger,{{2009,10,28},{15,56,23}},
     "Protocol: ~p: register error: ~p~n",
     ["inet_tcp",{{badmatch,{error,econnrefused}}
    The error is documented here: http://www.ejabberd.im/node/3709

    This page says to fix the error the following commands must be run as the root:

    Code:
    nattribute --set --nid virtual_system_name --flag ~single_ip
    echo "~single_ip" > /etc/vservers/virtual_system_name/nflags
    Is there any way that I can fix this myself? Are there any other solutions to this problem? If not, I think I may have to ask Westhost to do it, and I'm trying to avoid additional expense.

    Thank you =8^)
    Sharon Murphy

  2. #2
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,721

    Default

    We do not have root access only root like access. Have you tried running the command? Sometimes even though a documentation says you need to run something as root it will still work. If the command gives an error about not being root then you would need to contact WestHost.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •