Results 1 to 2 of 2
  1. #1

    Default WordPress Media Upload Permission Denied Problem

    I have the latest version of WordPress installed. It is working great except for the "media upload" feature. It has never worked and I am determined to figure out why, since I learned that it is working on another WordPress blog I manage that is hosted on a different non-WestHost server -- so this tells me that it is not the code or how I configure it. It is something WestHost-specific.

    The error I get when using the "browser upload" feature (not the Flash, which is another story) is "permission denied" for the file wp-admin/media-upload.php.

    I think it is a pathing problem. I am seeing the following path for the photos that are displayed now:

    /var/www/html/blog/wordpress/wp-content/uploads/2008/11/bkgd-grid.jpg

    but the default folder for my media uploads is "wp-content/uploads".

    Has anyone gotten this to work on WestHost and what are your settings for the default path?

  2. #2
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,720

    Default

    "Permission Denied" indicates that you do not have the permissions set correct for the directory: /var/www/html/blog/wordpress/wp-content/uploads/

    Log into your site via FTP and set the permissions to 0755 at the very least.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •