Results 1 to 9 of 9

Thread: Installing git?

  1. #1

    Default Installing git?

    Hi all. I'm new to westhost, and not much of a command-line wizard (yet!), and I ran into some trouble while following some pretty straightforward instructions to install git

    The install breaks on "make" like so:
    Code:
        SUBDIR git-gui
    GITGUI_VERSION = 0.10.1
        * new locations or Tcl/Tk interpreter
        GEN git-gui
        INDEX lib/
        * tclsh failed; using unoptimized loading
        MSGFMT    po/de.msg make[1]: *** [po/de.msg] Error 127
    make: *** [all] Error 2
    Any thoughts/links would be greatly appreciated...

  2. #2

    Default Re: Installing git?

    Even if you compile git from source (to get the latest), it is still wise to install as many of those other libraries as possible using “apt-get install ___”. This is faster, easier, will get future upgrades to the libraries automatically, and will make them available to other packages that need them.
    ----------------------
    williamgeorge
    Search Engine Optimization

  3. #3
    Junior Member
    Join Date
    Feb 2009
    Posts
    1

    Default Any progress on this?

    Hi,

    I was wondering if anybody had made any progress on this. I would really like to be able to use Git on my Westhost Account. I have tried setting the configure prefix=$Home so that I wouldn't need root privileges but this still doesn't work. If anybody has any more ideas it would sure be great. Thanks!

  4. #4
    Junior Member
    Join Date
    Mar 2009
    Posts
    1

    Default git install

    I just installed git on my westhost account and it seems to be working fine. Here are the steps I used:

    ./configure --prefix=$HOME --without-tcltk
    make
    make install

    Without tcltk prevents git from trying to build the git gui which wouldn't do any good here anyway. I tried installing to the normal /usr/local location, but ran into problems with the install script trying to change permissions on root-owned directories. If you install in your home directory, you may need to add '~/bin' to your path.

    - Keith

  5. #5
    Junior Member
    Join Date
    Aug 2009
    Posts
    1

    Default

    On the change permission problem, before "make install", vi Makefile, look for the line:
    "$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(bindir_SQ)'"
    .. and delete it. "make install" should run fine installing to /usr/local without error.

  6. #6
    Junior Member
    Join Date
    Apr 2009
    Posts
    5

    Default

    Quote Originally Posted by tufcamman View Post
    Hi,

    I was wondering if anybody had made any progress on this. I would really like to be able to use Git on my Westhost Account. I have tried setting the configure prefix=$Home so that I wouldn't need root privileges but this still doesn't work. If anybody has any more ideas it would sure be great. Thanks!
    3 years later, still can't git. I did what was suggested in this thread (took out tcltk and bindir_SQ) and no dice.

    /bin/sh: curl-config: command not found
    /bin/sh: ./generate-cmdlist.sh: Permission denied
    make: *** [common-cmds.h] Error 126
    GEN common-cmds.h

    Help..................

  7. #7
    Junior Member
    Join Date
    Apr 2009
    Posts
    5

    Default

    Quote Originally Posted by ecs1749 View Post
    3 years later, still can't git. I did what was suggested in this thread (took out tcltk and bindir_SQ) and no dice.

    /bin/sh: curl-config: command not found
    /bin/sh: ./generate-cmdlist.sh: Permission denied
    make: *** [common-cmds.h] Error 126
    GEN common-cmds.h

    Help..................
    Ok, chmod to 755, went a little further. Actually found the cmd:

    make NO_CURL=1 NO_MSGFMT=YesPlease NO_TCLTK=YesPlease prefix=/usr/local install

    more complete but now stuck at:

    /usr/local/perl-5.8.8/bin/perl -pe "s<\Q++LOCALEDIR++\E></usr/local/share/locale>" <Git.pm >blib/lib/Git.pm
    SUBDIR git_remote_helpers
    SUBDIR templates
    MSGFMT po/build/locale/da/LC_MESSAGES/git.mo
    /bin/sh: msgfmt: command not found
    make: *** [po/build/locale/da/LC_MESSAGES/git.mo] Error 127

    Now, got to go and hunt down msgfmt (I hate this!)

  8. #8
    Junior Member
    Join Date
    Apr 2009
    Posts
    5

    Default

    Quote Originally Posted by ecs1749 View Post
    Ok, chmod to 755, went a little further. Actually found the cmd:

    make NO_CURL=1 NO_MSGFMT=YesPlease NO_TCLTK=YesPlease prefix=/usr/local install

    more complete but now stuck at:

    /usr/local/perl-5.8.8/bin/perl -pe "s<\Q++LOCALEDIR++\E></usr/local/share/locale>" <Git.pm >blib/lib/Git.pm
    SUBDIR git_remote_helpers
    SUBDIR templates
    MSGFMT po/build/locale/da/LC_MESSAGES/git.mo
    /bin/sh: msgfmt: command not found
    make: *** [po/build/locale/da/LC_MESSAGES/git.mo] Error 127

    Now, got to go and hunt down msgfmt (I hate this!)
    The makefile changed. Now need to do:

    make NO_CURL=1 NO_MSGFMT=YesPlease NO_TCLTK=YesPlease NO_GETTEXT=YesPlease prefix=/usr/local install

    Finally! Works! Just say, for instance:

    git clone git://git.gnome.org/libxml2

  9. #9
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,720

    Default

    Glad you got it running. Sometime it just means keeping at it.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •