Results 1 to 3 of 3
  1. #1

    Question formmail path - "This Page Not Found" Error

    I'm trying to setup my formmail script. I have the following path in my contact.htm file:

    <form method="POST" action="" rel="nofollow" target="_top">

    And I have uploaded the file to:

    In my script, I have tried the lines:
    $mailprog = '/usr/lib/sendmail -i -t';

    AND,I also tried:
    $mailprog = '/usr/bin/perl';

    I wasn't sure which to use...

    When I test my form, I get this error:

    "The page cannot be displayed
    The page you are looking for is currently unavailable. The Web site might be
    experiencing technical difficulties, or you may need to adjust your browser

    And on the error page, the path in the URL reads:
    http://www.pipedreamsmarine. com/var/www/cgi-bin/formmail/

    (No space of course, but without it, it wants to make it an abbreviated link) But, it's not even the path I used!?

    Tech Support said that I needed to use:
    <form method="POST" action="" rel="nofollow" target="_top">

    (which, I did and it didn't work - see above) but that they couldn't assist further as I had a custom version of formmail (!?!?) (which I downloaded from and that if I needed further assistance to post in a forum or pay for custom services.

    I've been trying to figure this out for days and I'm just stumped & frustrated. Any advice?? It'd be greatly appreciated!
    Last edited by Pipe Dreams Marine; 09-03-2008 at 10:52 AM.

  2. #2
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Kansas City Mo


    Why aren't you simply using the WH provided FormMail script? Is this perhaps for a secondary domain and not the main one? Do you have any .htaccess files that you are using in your public web directories?

    If you are going to use Form Mail, do not use the one from Script Archive. Instead use the one here: Neither of these versions are the best choice as they are no longer being maintained to keep up with current spamming techniques but the second choice may give you better security.
    Please remember your charity of choice:

    Handy Links: | Plain Text Editors: EditPlus | Crimson

  3. #3
    Junior Member
    Join Date
    Oct 2004


    Hello Pipe Dreams,

    Here's one thing to check...

    AFTER you uploaded the perl file to your cgi-bin, did you change the file permissions? The script won't work unless you chmod it to 755.

    Let me know if that does the trick (depending on which $mailprog line of code your using in the perl script).

    You mentioned two different $mailprog lines of code. If neither of them work after changing the file's permissions, then try the following for your $mailprog line....

    $mailprog = '/bin/sendmail -i -t';

    Just remember, you MUST chmod the file to 755 (every time) after it is uploaded.

    Hope this helps,

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts