Page 4 of 4 FirstFirst ... 234
Results 31 to 35 of 35
  1. #31
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,720

    Default

    Newer versions of ffmpeg tries to access hardware like video cards and such on the system they are installed on. We don't have that option here. In fact even over at vps.net where they have an image you can install with ffmpeg, I am pretty sure it is an older version because in a hosting environment you don't have access to the video card... in fact I am pretty sure there isn't one.

    Now with that being said, I did do some current searching on this and it could be that this would let you get past the problem. http://eitwebguru.com/fix-make-libav...v4l-o-error-1/. They where able to disable v41 and v42 when configuring ffmpeg to get past this error.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  2. #32

    Default

    Thanks for that info. Got me pass it and it installed.

    Now when I get to install ffmpeg-php. I Get this error.

    Code:
    /usr/local/ffmpeg/include/libavformat/avformat.h:250: error: storage size of `pix_fmt' isn't known
    make: *** [ffmpeg-php.lo] Error 1
    What do you think I can do to get passed this last hurdle?

  3. #33
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,720

    Default

    I bet you can disable it... well maybe. Try configure --help and see if it gives you any details on what you can disable during the configure process. I didn't have much luck on Google but you might have better luck then me. the pix_fmt is I think the key. I know at one time I read something about this and folks having errors but can't find it now. Could be a read it over at the vps.net forum so that might be a place to check out.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  4. #34

    Default

    I Gave up. 2 hours on Google and no joy

    But it's not a big issue. I Don't think I need it right now.

    I have got my FFmpeg installed and it is doing the job I want it to do. Working on a new version of www.OnlineTruckers.org Using JomSocial with video uploading enabled. Now I have to just get it working with iPhones and I will be happy
    Last edited by Oddsodz; 05-05-2010 at 02:52 PM.

  5. #35
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,720

    Default

    I beat it! It took some time but I finally figure out what was going on. You have to do some extra work to get ffmpeg_php going since we ffmpeg itself is installed in a location that is not default.

    I noticed that when running make it was complaining early on about not being able to include files. I created some symbolic links in /usr/local/include on a long shot and it worked. So log in via SSH and then issue these commands. Now the code below does assume that you where following the directions at the first of this post and that when you installed ffmpeg to start with you did it with --prefix=/usr/local/ffmpeg. If not you need to change the paths below to match what you did use.
    Code:
    cd /usr/local/include
    ln -s /usr/local/ffmpeg/include/*
    ln -s /usr/local/ffmpeg/include/libavcodec
    ln -s /usr/local/ffmpeg/include/libavdevice
    ln -s /usr/local/ffmpeg/include/libavformat
    ln -s /usr/local/ffmpeg/include/libavutil
    That fixed the error you where having but I still ran into a problem with libsswscale. I don't know if it was just something I did but when I first installed ffmpeg or what, but I did have to go back and install that. If it is not installed then you won't have a /usr/local/ffmpeg/include/libsswscale directory. More then likely I could have just copied from the source directory but I went ahead and ran the make and make install for that library. I am not sure where you decompressed your orginal sources but I just did it at root so the code below is a reflection of that.
    Code:
    cd /ffmpeg-0.5.1/libsswscale
    make
    make install
    Once you take care of the above you should be good to go on installing ffmpeg_php. Just to be safe I ran make distclean first then ran ./configure again.
    Code:
    cd /ffmpeg-php-0.6.0
    make distclean
    ./configure --with-ffmpeg=/usr/local/ffmpeg
    make
    make install
    I hope that gets you going. When I get some time I want to do a new tutorial on this with all the steps from start to finish. I think at this point if anyone visited this thread they would get a bit lost.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •