Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 35
  1. #21
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,720

    Default

    configure would not be in /usr/local/bin. It would be in the directory where you downloaded and unzipped the PHP source files.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  2. #22
    Junior Member
    Join Date
    Apr 2009
    Posts
    7

    Default

    On this issue:

    The last step on Dattas post needs a little fixing. I am not sure what changed since this post, but it appears you cannot edit the /etc/ld.so.conf file as it is a root file our VPS accounts cannot edit.

    Instead you need to create a ffmpeg.conf within the /etc/ld.so.conf . d directory (just make one using vi), add /usr/local/ffmpeg/lib to the file, then save. Afterwards run ldconfig and it should work.

  3. #23
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,720

    Default

    /etc/ld.so.conf should be owned by you. my accounts are still that way. Then again my accounts are older so it is good to know there is an alternative if newer accounts are created with the file owned by root.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  4. #24
    Junior Member
    Join Date
    Apr 2009
    Posts
    7

    Default

    Actually, so is mine. But for some reason lots of thins are not working:

    wget is not working and I cannot change permissions on the mentioned file or any of the bin, lib or includes folders within /usr/local/ .

    trying to compile x264 now and I am sooooo out of luck. Even after installing nasm...it fails because the permissions issue above.

    SInce I got your attention...I do have an ffmpeg binary with all the goodies in it, but I can't seem to figure out how to use it.

    How exactly do you use the ffmpeg binary? Just upload and use?

    Funny thing, I was at VPS.net for a month or so and now that I am back in here I can see the huge advantages of VPS.net for this sort of thing.

  5. #25
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,720

    Default

    This is still a WH 3.0 account correct? I am pretty sure you would not have /usr/local in WH 4.0 but figured I should clarify that one since you said you where over at VPS.net then returned here.

    Not sure what files you would need to change permissions on. True you may not have premission to write to some existing files but that is why you would us --prefix=/usr/local/ffmpeg when configuring things. That is actually why you would then run the ln commands while in /usr/local/bin that has towards the end of his post. Since you used the prefix /usr/local/ffmpeg it created the bin directory in that directory. You still have write access to /usr/local/bin where you want to create the links (ln) to the binaries.

    If wget is not working on your account then something is not right. Have you asked WestHost about that?

    If you have the binaries you could try and upload them to /usr/local/bin but I am not sure that in this case that would work. Where did you get the binary?
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  6. #26
    Junior Member
    Join Date
    Apr 2009
    Posts
    7

    Default

    First of all...thanks for the replies. I have seen this post many times and even posted once but I figure it was so old you were out of the loop...

    yes, still a 3.0 account.

    As for the prefix....I think I figure that part out as I was doing it, still no dice.

    I found the binaries at a CentOS site somewhere in the hudred of links I search. I got ffmpeg working, just the x264 that is killing me.

    I am gonna try it again in a little while.

    And no wget is not working, no nasm....

  7. #27
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,720

    Default

    What error do you get when you try to use wget? Actually you should be able to contact WestHost about wget and they should be able to check and make sure it is working. nasm would not be installed by default on our accounts. You would need to install it yourself.

    It is kind of hard to guide you since you are not giveing any specifics but don't forget that you may need to use --prefix=/usr/local/theapp when your run configure is you are running in to write permission issues. theapp would be replaced with the name of what ever you are trying to install.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  8. #28
    Junior Member
    Join Date
    Apr 2009
    Posts
    7

    Default

    You kidding me man? You are already more help than I expected.

    I am running Drupal + ffmpeg wrapper. I installed and compiled ffmpeg and it is working fine in Drupal. The Test Conversion works, at least for the video formats I tested....except h264. So I moved to install x264 and it seems I kept running into dead ends:

    I used the latest x264 snapshot from git via http.

    First of all it would not compile because it kept telling me I needed nasm. I was under the impression yasm would work, but it did not, so I installed nasm.

    The ./configure I used for the install was:

    ./configure -with-ffmpeg=/usr/local/ffmpeg
    And gave me this in result:

    Unknown option -with-ffmpeg=/usr/local/ffmpeg, ignored
    Platform: X86
    System: LINUX
    avis input: no
    mp4 output: no
    pthread: no
    vfw: no
    debug: no
    visualize: no

    You can run 'make' now.
    On make everything seemed fine, but on make install I got these errors:

    install -d /usr/local/bin /usr/local/lib /usr/local/include
    install: cannot change permissions of `/usr/local/bin': Operation not permitted
    install: cannot change permissions of `/usr/local/lib': Operation not permitted
    install: cannot change permissions of `/usr/local/include': Operation not permitted
    So I tried changing he permissions on those three via ssh (so I could see groups). No dice. I cannot and I presume because they are root.

    So I was about to give up. I saw somebody else had posted on the x264 and this is the only thread that mentioned it..

  9. #29
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,720

    Default

    Well again it comes down to "where" you are trying to install. By default when you install something a prefix of /usr/local is used. That means that the program is trying to modify /usr/local/bin, /usr/local/lib and /usr/local/include. While we have some rights in these directories you are correct we do not have full root access to them since they are owned by root. You should be able to use --prefix=/usr/local/x264 when you configure it. To make sure type ./configure --help and it should give you output of what can be used when configuring x264. You might have to link to the binaries that are created in /usr/local/x264/bin like you did with ffmpeg and add the /usr/local/x264/lib to your /etc/ld.so.conf and run ldconfig.

    What some folks at WestHost have done is create a "/usr/local" directory that thy use for their own installs. For example if you check this page http://www.domsch.com/westhost/ , Matt on some occasions uses the prefix of /home/myusername. Since that is a directory he created he has full access to it and the bin,lib and include directories that are in it. Then he adds /home/myusername/lib in his /etc/ld.so.conf. In this way he does not have to keep going through the last step of adding a new lib directory on each install. I know it is a bit late for you to do this but for others who are reading this it might be worth setting up.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  10. #30

    Default

    Hello all.

    This maybe an old thread. But I have hit a brick road. I Have followed all the instructions and it has worked all the way (including mp3 support and libvorbis) until I get to

    Code:
    make && and make install
    If you look at the picture attached. You will see an error about "tuner". Now I am a linux noob. So I am at a lost as to what to do next.

    Hope somebody can help.

    Oddsodz
    Attached Images Attached Images  

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •