Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Sep 2007
    Location
    Austin, TX
    Posts
    15

    Default Connection reset by peer

    Does anyone know if there's a way we can increase the connection timeouts for SSHD and MySQL server?

    It's annoying to get "Connection reset by peer" and have to log in again when I've not been using the connection for a few minutes.

    Thanks!
    Phil

  2. #2
    Senior Member
    Join Date
    May 2005
    Posts
    130

    Default

    that's probably your router doing that. i keep ssh connections open for weeks. i had to turn on keepalives in ssh (on linux) to do that, otherwise the router (dlink di-604) would time out the connection.

  3. #3
    Junior Member
    Join Date
    Sep 2007
    Location
    Austin, TX
    Posts
    15

    Default

    allyn,
    thanks for the reply.

    Issue resolved... I added the following to my ~/.ssh/config file:
    #TCPKeepAlive yes
    ServerAliveCountMax 10
    ServerAliveInterval 15

    The TCPKeepAlive did not work, so it appears the two ServerAlive options are needed. BTW, I'm on an OS X (10.4) client.

    Phil

  4. #4
    Senior Member
    Join Date
    May 2005
    Posts
    130

    Default

    i use "KeepAlive yes" and "ServerAliveInterval 500" and that does the trick. i would have posted that the first time but i wasn't home when i responded.

  5. #5
    Junior Member
    Join Date
    Sep 2007
    Location
    Austin, TX
    Posts
    15

    Default

    Thanks again!

    I've settled on these settings (pings every 5 minutes, gives up after 3 tries):
    TCPKeepAlive yes
    ServerAliveCountMax 3
    ServerAliveInterval 300

    Phil

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •