Results 1 to 4 of 4

Thread: htmldoc

  1. #1
    Junior Member stevenh's Avatar
    Join Date
    Dec 2007
    Posts
    3

    Default htmldoc

    I have a client who is very tech savvy, and he is requesting the use of htmldoc on his account for creating pdfs from HTML. I installed the source version 1.8.27 and it appeared to install correctly in his home directory bin and share. For extra measure, I created a symbolic link for htmldoc in the /usr/bin directory that points to the actual executable in the /usr/home/username/bin directory, but he says it is not working. Does anyone have experience with this and a suggestion on how to test if it is working?
    Last edited by stevenh; 12-20-2007 at 05:38 PM. Reason: More pertinent information

  2. #2

    Default

    StevenH,

    Just curious, are there any errors showing up in the error logs? It's a bit hard to offer much relevant advice without knowing what errors are being generated. If there are any messages about errors being sent to /var/log/httpd/error_log then post those for us to see.

    Other suggestions, Does it work if he calls the program in the installed location instead of the symlink? Is it potentially a library issue with the installed libraries not being found?

  3. #3
    Moderator wildjokerdesign's Avatar
    Join Date
    Jun 2003
    Location
    Kansas City Mo
    Posts
    5,721

    Default

    I thought htmldoc was an rpm, how did you install it? You can't use rpm's on a WestHost account. If I am wrong about that and you installed it using GCC and ./configure, make, install then you might need to run it as a cgi program.

    Create a symbolic link to your cgi-bin:
    Code:
    ln -s /usr/home/username/bin/htmldoc /var/www/cgi-bin
    Refrence: http://www.easysw.com/htmldoc/htmldoc.html#CGI

    If you are using it with PHP then make sure that the function used is activated. Remember by default WH installs of PHP restrict some functions. The passthru function is one suggested for use on the htmldoc site and that is one that can be turned off. Go to Site Manager > Site Applications and check your version of PHP by clicking on the Edit icon.
    Shawn
    Please remember your charity of choice: http://www.redcross.org

    Handy Links: wildjokerdesign.net | Plain Text Editors: EditPlus | Crimson

  4. #4
    Junior Member stevenh's Avatar
    Join Date
    Dec 2007
    Posts
    3

    Default PHP and CGI - now works

    Thanks for the suggestions. Every indication I am hearing from the client is that it is working now that we changed the PHP config and created the cgi symlink. I wish I knew for sure which one fixed it. My suspicion is the PHP. I set the passthru() function.

    Yes, I did install this using the ./configure, make and make install.

    Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •