Results 1 to 7 of 7
  1. #1
    Junior Member
    Join Date
    Jun 2007
    Posts
    6

    Default Error with ncurses5.6 and make

    I am trying to install ncurses5.6 into my /home/phototourwebsites. The process looks
    pretty straight forward, however after successfully running the following configure
    command:

    ./configure --with-shared --with-normal --without-debug --enable-overwrite
    --prefix=/home/phototourwebsites

    I then have problems running make. Here is the output from make:

    $ make
    cd man && make DESTDIR="" all
    make: Entering directory `/usr/home/phototourwebsites/ncurses-5.6/man'
    sh ./MKterminfo.sh ./terminfo.head ./../include/Caps ./terminfo.tail >terminfo.5
    make: Leaving directory `/usr/home/phototourwebsites/ncurses-5.6/man'
    cd include && make DESTDIR="" all
    make: Entering directory `/usr/home/phototourwebsites/ncurses-5.6/include'
    cat curses.head >curses.h
    AWK=gawk sh ./MKkey_defs.sh ./Caps >>curses.h
    sh -c 'if test "chtype" = "cchar_t" ; then cat ./curses.wide >>curses.h ; fi'
    cat ./curses.tail >>curses.h
    sh ./MKhashsize.sh ./Caps >hashsize.h
    AWK=gawk sh ./MKncurses_def.sh ./ncurses_defs >ncurses_def.h
    AWK=gawk sh ./MKparametrized.sh ./Caps >parametrized.h
    gawk -f MKterm.h.awk ./Caps > term.h
    sh ./edit_cfg.sh ../include/ncurses_cfg.h term.h
    ** edit: HAVE_TCGETATTR 1
    ** edit: HAVE_TERMIOS_H 1
    ** edit: HAVE_TERMIO_H 0
    ** edit: BROKEN_LINKER 0
    make: Leaving directory `/usr/home/phototourwebsites/ncurses-5.6/include'
    cd ncurses && make DESTDIR="" all
    make: Entering directory `/usr/home/phototourwebsites/ncurses-5.6/ncurses'
    gawk -f ./tinfo/MKnames.awk ./../include/Caps
    cat namehdr boolnames boolfnames numnames numfnames strnames strfnames nameftr
    >names.c
    cat namehdr boolcodes numcodes strcodes codeftr >codes.c
    rm -f namehdr nameftr codeftr boolnames boolfnames boolcodes numnames numfnames
    numcodes strnames strfnames strcodes
    made codes.c
    gcc -o make_hash -DHAVE_CONFIG_H -I../ncurses -I. -I./../include -I../include
    -DHAVE_CONFIG_H -I../ncurses -I. -I. -I../include -D_GNU_SOURCE -DNDEBUG
    -I/home/phototourwebsites/include -O2 -DMAIN_PROGRAM ./tinfo/comp_hash.c
    In file included from /usr/include/errno.h:36,
    from ../ncurses/curses.priv.h:84,
    from ./tinfo/comp_hash.c:42:
    /usr/include/bits/errno.h:25:26: linux/errno.h: No such file or directory
    In file included from /usr/include/signal.h:307,
    from ../ncurses/curses.priv.h:115,
    from ./tinfo/comp_hash.c:42:
    /usr/include/bits/sigcontext.h:28:29: asm/sigcontext.h: No such file or directory
    make Error 1
    make: Leaving directory `/usr/home/phototourwebsites/ncurses-5.6/ncurses'
    make: *** Error 2

  2. #2

    Default

    ebraden,

    You won't be able to install directly to /usr/include or any of it's subdirectories. Those directories are root-owned, making them only writable by WestHost systems administrators.

    However, you should still be able to install your app. To do so, just update the make or config file to install to a directory that is not root owned, such as /usr/local.
    Last edited by WestHost - MCox; 06-07-2007 at 12:47 PM.
    Sincerely,

    Mark Cox
    Data Center Administrator
    WestHost

    When you expect more from your Web host
    http://www.westhost.com/

  3. #3
    Junior Member
    Join Date
    Jun 2007
    Posts
    6

    Default

    I dont see anywhere obvious in the Makefile to set this and there is no file called config in the ncurses5.6 root folder. I tried setting the DESTDIR variable in the Makefile to /usr/local but still get the same result.

    What exactly must I do in the Makefile?

    Thanks for your help.

  4. #4
    Senior Member rolling's Avatar
    Join Date
    May 2004
    Location
    Different day, different place
    Posts
    486

    Default

    Quote Originally Posted by ebraden
    I dont see anywhere obvious in the Makefile to set this and there is no file called config in the ncurses5.6 root folder. I tried setting the DESTDIR variable in the Makefile to /usr/local but still get the same result.

    What exactly must I do in the Makefile?

    Thanks for your help.
    Nothing You need to run ./configure with a different --prefix.

    I managed to install ncurses (with a little work around). See this post

    PS I never build in /usr/local because of access troubles. I use /usr/mylocal
    Richard

    I have jotted down some of my meddlings at http://www.rollingr.net/wordpress
    Click here for a full list of formatting codes for this forum

  5. #5
    Junior Member
    Join Date
    Jun 2007
    Posts
    6

    Default

    still not working i have tried using both /home/phototourwebsites and /usr/mylocal as a prefix. and still getting the same exact error when running Make.

    Isnt the "work around" that you reference for linking to ncurses during the python build. I am not getting that far....Make fails.
    Last edited by ebraden; 06-07-2007 at 04:06 PM.

  6. #6
    Senior Member rolling's Avatar
    Join Date
    May 2004
    Location
    Different day, different place
    Posts
    486

    Default

    Did you try just ./configure --prefix=/usr/mylocal ? Forget the other parameters for now; you only need to use them if that does not work. Don't forget that you will have to to create /usr/mylocal manually first.

    I suspect that your problem may be the use of --with-shared and --with-normal. However, without looking at the code, I cannot tell if these are mutually exclusive.

    --with-shared generate shared-libraries
    --with-normal generate normal-libraries (default)
    --with-debug generate debug-libraries (default)

    Fine-Tuning Your Configuration:
    --disable-overwrite leave out the link to -lcurses
    Richard

    I have jotted down some of my meddlings at http://www.rollingr.net/wordpress
    Click here for a full list of formatting codes for this forum

  7. #7
    Junior Member
    Join Date
    Jun 2007
    Posts
    6

    Default

    OK ... problem was solved by uninstalling Gnu compiler in manager/site applications and then re-installing it. I had installed other development packages like ruby, mod perl, etc so I suspect that one of these other package installations broke the gnu compiling environment.

Similar Threads

  1. HowTo Guide: Installing Subversion
    By Pachango in forum General Discussion
    Replies: 25
    Last Post: 12-17-2008, 10:08 AM
  2. How to make PHP5 for a VPS account
    By dzenav in forum General Discussion
    Replies: 16
    Last Post: 09-03-2006, 07:16 AM
  3. Spamassassin upgrade isn't working - part 2
    By bstreet in forum E-mail / FTP Management
    Replies: 2
    Last Post: 06-10-2005, 02:16 PM
  4. Shopping Carts 101 - A basic primer
    By gbanse in forum E-commerce
    Replies: 2
    Last Post: 09-23-2003, 10:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •