PDA

View Full Version : Upgrade to VPS Shared SSL



ccwebb
02-26-2007, 06:43 PM
I got an email from WestHost informing me that I had to move one of my pages off of the "old" secure server. The procedure they have for this says copy off all of your files off to your local computer and upload them to var/www/html/secure (I have to create the secure folder). I would then access thru the shared ssl.

I did that - and it included loading a cgi-bin from the old secure server and putting it under the secure directory. I questioned support about this and was told it would work. (I also had to re-establish all of my permissions on the cgi files)

Anyway, testing showed that calls to cgi programs failed with an internal server error so I called support again. Now they are telling me I should move my cgi programs from the secure folder and just put them into the regular cgi-bin (/var/www/html/cgi-bin). Of course, I also have to change the calling programs to address the new location.

Before I go thru all this work I would appreciate some feedback from someone that tells me I am now on the right track.

jponiato
02-27-2007, 11:12 AM
I got an email from WestHost informing me that I had to move one of my pages off of the "old" secure server. The procedure they have for this says copy off all of your files off to your local computer and upload them to var/www/html/secure (I have to create the secure folder). I would then access thru the shared ssl.

I did that - and it included loading a cgi-bin from the old secure server and putting it under the secure directory. I questioned support about this and was told it would work. (I also had to re-establish all of my permissions on the cgi files)

Anyway, testing showed that calls to cgi programs failed with an internal server error so I called support again. Now they are telling me I should move my cgi programs from the secure folder and just put them into the regular cgi-bin (/var/www/html/cgi-bin). Of course, I also have to change the calling programs to address the new location.

Before I go thru all this work I would appreciate some feedback from someone that tells me I am now on the right track.

You should be able to direct apache to the right place for cgi calls within your secure context. I assume this context is defined as a virtual host? In any case, within your httpd.conf file the virtual host will be defined. There you can create the following lines:

ScriptAlias /cgi-bin/ /path/to/secure/cgi-bin/
<Directory /path/to/secure/cgi-bin>
AllowOverride None
Options +ExecCGI
Order allow,deny
Allow from all
</Directory>

This should tell apache to use /path/to/secure/cgi-bin/ whenever it sees a reference to /cgi-bin/ within your secure context. It also makes apache aware that files there should be considered executable. Good luck. Oh - make a backup copy of httpd.conf first, just in case.

ccwebb
02-28-2007, 01:33 PM
jponiato:
Thanks for the response. Changing the httpd.conf file is too intimidating for me.

I am going to go ahead and try to make the change Westhost suggested the second time.

Charlie