View Full Version : PHP 5.2 required for WordPress: Why??

02-24-2007, 10:46 PM

I am currently running PHP 4.4.2 and I am pleased with it. I do not want to upgrade to PHP 5.2. But...

I would like to install WordPress 2.0.7 via the "Site Applications" page. That installation link tells me that I must also install PHP 5.2 in order to install WordPress 2.0.7. I find that puzzling because the WordPress site says that the minimum requirement for WordPress 2.1 is PHP 4.2. If PHP 4.2 is good enough for WordPress 2.1, then why is westhost insisting that I use PHP 5.2 for an even earlier version of WordPress?

I'd rather not move up to PHP 5.2 because it might break some of my pages that were written for PHP 4 - and I'm not in a hurry to find out.

What can I do to install WordPress on westhost without also going through with the unnecessary (according to WordPress) PHP 5.2 upgrade?

Thanks, in advance.

02-25-2007, 08:22 AM
You would need to install it manually. Not to difficult with Wordpress they have information on how to do that on thier site. You would need to create the database yourself and that can be done by first installing phpMyAdmin via the Site Manager and useing it.

02-25-2007, 11:42 AM
Thanks for the help, mission accomplished!

I created the database in phpMyAdmin, downloaded and manually installed WordPress 2.1, and it all worked fine - just as you described. I now have WordPress 2.1 running with PHP 4, which is exactly what I wanted.

Thanks again! :)

02-26-2007, 09:35 AM
Just for clarification for anyone else with this question, Wordpress 2.0.7 will also work with WestHost's PHP 4.4.4. The site manager automatically prompts you to install the "latest" version, and out of 4.4.4 and 5.2.0, 5.2.0 is the latest. If 4.4.4 was already installed it wouldn't prompt you to upgrade and you'd be able to install WordPress just fine. So in other words, the version that it prompts you to install may not always be the *only* version that it will work with.

02-26-2007, 09:40 AM
Ahh... I see so since yourinternetradio was still running 4.4.2 which is not supported by WH anymore they could have simply upgraded to 4.4.4 and they would not have been prompted. :) It sounds like it would be a good idea for WH to prompt for the current supported 4 or 5 version... hmmm.

02-26-2007, 02:46 PM
aha. this must be the same reason why when i tried to upgrade phpmyadmin i was told it required php 5.2.0. i am running php 4.4.2 right now.

btw, php 4.4.2 is listed as "Mod Php 4.4.2" but 4.4.4 is just listed as "PHP 4.4.4". this is still mod_php, right? they haven't switched to the cgi-bin version, have they?

02-26-2007, 03:50 PM

Yes it is still mod_php even though it doesn't say it in the name anymore.


02-26-2007, 04:08 PM
thanks blender. i guess i should upgrade.