PDA

View Full Version : IP order recorder broken



winterhawk
10-12-2006, 07:15 PM
I just recently moved my osc site from a shared server to a dedicated server with westhost. Now the IP Recorder is broken and instead of showing me the customer IP/ISP it shows an IP for westhost and their name under ISP. I believe the IP recorder for my contact me is also broken this same way. However, the who's online still works just fine.

Any ideas on how/where to look to correct this problem?

wildjokerdesign
10-13-2006, 05:54 AM
Have you contacted WestHost support about this? It sounds more like it may be something to do with the account setup instead of something that would need to be edited in OSC.

winterhawk
10-13-2006, 03:54 PM
I think the problem here has to do with using westhost's shared SSL, it's not handled the same way as my previous host I guess.

wildjokerdesign
10-13-2006, 04:16 PM
Ah yes I am pretty sure that shared SSL would affect this. I think the only option is to purchase your own certificate unless WestHost support can come up with something else.

winterhawk
10-14-2006, 06:30 PM
I installed my own SSL and the problem is gone. Westhost support was very helpful though, they offered some suggestions for the php.code that might fix it when using the shared, but I didn't test it out.

wildjokerdesign
10-15-2006, 09:45 AM
Glade the purchased certificate for SSL worked out your problem!

Would you mind posting what WH support suggested for php code changes? It might help someone down the road who does not want to go with their own certificate.