PDA

View Full Version : problem installing everyauction



Artisans_Square
07-14-2006, 08:25 PM
Hello again! :)

I've been trying all day to install everyauction. This has to be the world's simplest script, and I've installed it at least a hundred times on other servers. But for some reason, I just cannot get it to work here. I keep getting an internal server error.

Also, I don't know where my error log is, so I can't look at it to figure out where the problem might be.

I have two of these currently up-and-running on other sites, and have tried just directly copying them over (so I would know I have workable scripts), and changing the paths but it doesn't work. Finally, I downloaded the latest version (with no add-ons or extras) and fought with it for almost four hours -no go.

Does anyone have any idea what I'm doing wrong? I'm really not new at this, but I am new to VPS, so maybe I've installed something incorrectly or need some other component that I don't have?

Any advice you can give would be appreciated muchly, so a BIG thank-you in advance: :)

THANKS!


~DL

wildjokerdesign
07-15-2006, 09:17 AM
Could you give use some idea of what/where you are installing it? A link to the program would help also although I will try to google and find it. That would let us look at the requirements and see if maybe there is something the VPS would not have that it needs. You did change your permissions on the correct files right? :)

wildjokerdesign
07-15-2006, 10:46 AM
DL,

I found the program, downloaded it and installed with very little problems. The program did give me a server error on first run but that was because I had not altered the orginal config setting of basepath. :) Once I pointed that to a valid direcory all was fine.

Here are a few things I can think of that may be causeing you a problem. First make sure you have perl installed via your Site Manager > Applications interface. I think version 5 up is all that WH offers so you should be fine. I was running it on an account that had the lastest availble at WH. Make sure you are installing the file in /var/www/cgi-bin/ and that you have set permissions to 755. I think you can create the basepath directory pretty much anyplace you want but I created my test at /var/www/auctiondata/

I only did a quick test of things and when I registered a new user I did not recieve an email with the password but was able to grab it from the data file. (Note the passwords are in plain text no encryption with this script so that is why it is best to place the basepath some place outside of /var/www/html). Looking at the config I realized that the default is set up for SMTP. You may want to uncomment $config{'mailprog'} for WH VPS the path to sendmail is /usr/sbin/sendmail. (Paths Info (http://members.westhost.com/software-paths.html) that may be useful to you on other things.)

BTW your error log is located at /var/log/httpd/error_log. You will find the other default logs in that directory also if you need them some place down the line.

Artisans_Square
07-15-2006, 11:22 AM
Thanks, wildjokerdesign, for the hints so far.


First make sure you have perl installed via your Site Manager > Applications interface.

I've installed the latest version, but was beginning to wonder if I needed another module or something.


Make sure you are installing the file in /var/www/cgi-bin/ and that you have set permissions to 755. I think you can create the basepath directory pretty much anyplace you want but I created my test at /var/www/auctiondata/

Yes; am doing that. And my test is the same as your test. Still no go. I even triple-checked to make sure my ftp clients were uploading in the proper format.

I've had a heavily modified version running on another site for nearly five years. I had to move it because my hosts there suddenly decided to halve everyone's disk quota. So I downloaded full backups and deleted the scripts...a serious mistake, as now I don't have the original-working-perfectly version to compare to.

After fighting with it for hours, I downloaded a fresh version from everysoft, but couldn't get it to work, either.

I finally broke down and called support; but I haven't received an email back from them, and I don't want to mess with them 'till I know if they had any success because I don't want to overwrite it if they get it working. :(


BTW your error log is located at /var/log/httpd/error_log. You will find the other default logs in that directory also if you need them some place down the line.

Thank-you! The errors are always cryptic, but they do usually give some hint as to where the troubles lie.

:)

wildjokerdesign
07-15-2006, 11:44 AM
I did check the error logs when I got the Internal server error but it was not much help really. :)

I am not sure why this is not working on your account. Do you have any other cgi-perl scripts running? If you wanted to PM me the config settings of your version I could take a look and see how they compare to what I had. Don't know if that would get use anywhere or not.

The script is just not that complicated really. Do double check all the settings and directories again. When I first set things up I misspelled my directory in the config and it took me about 10 mins before I realized it. :)

I go back and look at my test and see if there is anything else I can think of.

Artisans_Square
07-15-2006, 11:59 AM
Well, I just found one error - a missing / before a ' - that I know will gum up the works.

So I've made another copy with a different name, and will try running it. If it doesn't work, I'll pm you with all the information. I'm really going nuts with this -it usually takes about an hour to get it up and running, and the fact I was on this all day yesterday with no luck is really frustrating.

wildjokerdesign
07-15-2006, 12:01 PM
I thought I would go ahead and post the relevant config settings I am used so you could compare just in case that may be a problem.



$config{'basepath'} = '/var/www/auction/';
$config{'closedir'} = 'closed';
$config{'regdir'} = 'reg';
%category = (
test => 'Test Catagory',
);
$config{'mailprog'} = '/usr/sbin/sendmail -t';
$config{'scripturl'} = 'http://example.com/cgi-bin';


Yes example should be replaced with your domain name. ;)

wildjokerdesign
07-15-2006, 12:02 PM
See you posted while I was. I bet it is that typo that is getting you. I do it all the time. Do feel free to PM me if you need to.

Artisans_Square
07-16-2006, 04:30 PM
Well, I found the problem with the fresh copy -one of the variables was commented, and shouldn't have been. I've no idea how it got that way, or how many times I looked at it before I saw it. :rolleyes:

I just wanted to say "Thanks" again for all the help. I was really going nuts with this thing...I'm not exactly new, and the fact this just wouldn't work was making me insane. :mad:

But it's up now, and I can add my mods one at a time 'till I get it the way I want it again. :)

wildjokerdesign
07-17-2006, 09:54 AM
Glad you where able to find the problem. I don't know how many times I have had the same thing happen only to realize it is something simple I was overlooking. :) The eyes just seem to get crossed after looking at code for so long. There just seems to come the time where you have to stop and come back to it another day. For the most part when I return to the project I will see what I was missing the first time around.

Artisans_Square
07-17-2006, 10:15 AM
It really helped that you got it running. I knew then it had to be in the script, and not some server abnormality...unless I was missing some vital component.

wildjokerdesign
07-17-2006, 02:52 PM
It really is a nice little program. I prefer PHP over Perl so I think I am going to try and code something similiar in PHP since there is some functionality I would like to ad. I have one community site where I think they would like it as a feature. I should be able to tie into the existing user database so they don't have to go through the registration process. :)

Artisans_Square
07-18-2006, 03:37 PM
Wow! I'd love to see that!

There is a php version, but no one has worked on developing it for years. I thought about playing with it a bit, but never really learned php well enough.

Anyway, the everysoft page has a bunch of files and links and a whole community of people who have done different things with the script. I've added a whole bunch of mods to mine -if you'd like to see, it's temporarily installed and running here: http://artisanssquare.com/cgi-bin/auction.pl
You can play with it, if you'd like. Registering right now adds $5.00 to your account, so you can add test auctions and see how it all works.

I don't know how long it will be up; as I plan to move it to a more secure location before it opens for business. :) When I do, I'll delete all the existing test accounts. :) In the meantime, I'll be adding more stuff and changing the way it looks and generally giving myself headaches. :p

TheJag
02-16-2009, 01:12 PM
Okay well im a total looser in the art of sites ....
I cant make what to do with the the .pl file i downloaded PERL, and i edited the file like it said in the readme,
and zippo !!!!

can sm1 please help me by linking his WORKING script file, so i can see what the hell im doing wrong ?

I would me very greatful

wildjokerdesign
02-17-2009, 07:39 AM
It has been about 8 months since I looked at this and I don't think I even have the script around any more. Did you have a look at my example of the config files on the firsts page? Are you using a plain text editor like one of them listed in my signature below to edit the files? Did you upload your files in ASCII mode? Did you change the permissions? Are you getting a server error when you try to access the program or something else?