View Full Version : Having Trouble

04-26-2006, 07:48 PM
I am a newbe to this program. I have basically have a simple website using miva & paypal. I thought this would be the easy way to start. I am receiving payments for orders in my paypal account just fine. The orders come through with no order information from Miva. I thought some of the experts on this forum might make quick work of my questions. Please Help!



04-27-2006, 07:31 AM

Did you see this on Miva's site?

I am using the PayPal Instant Payment Notification module in Miva Merchant 4.14 and higher, but I am not seeing any of my orders under Order Processing. Why is that? (http://smallbusiness.miva.com/resources/faq/faq.mv?Faq_Code=FAQ&FAQ_Entry=PAYPAL-1&Category_Code=PAYPAL)

In order for Miva Merchant to be notified of any orders that get placed through the PayPal Instant Payment Notification module built-in to Miva Merchant 4.14 and higher, there are a few things that you need to check on:

· You must have a PayPal Business Account. The module is designed to work with this specific type of PayPal account.

· You must have Instant Payment Notification (IPN) turned on in your PayPal manager.

The steps below will walk you through how to do this second part, turning on Instant Payment Notification, also known as "IPN".

1. Login to your PayPal account manager. You can login at www.paypal.com.

2. Once logged in, click on the tab at the top titled "Profile".

3. On this Profile screen, under the ‘Selling Preferences’ column, click on the link "Instant Payment Notification Preferences".

4. On this Preferences screen, you will see what your settings are currently. More than likely, this is set to OFF already. Click on the Edit button to make changes.

5. On the Edit screen, check in the box next to Instant Payment Notification (IPN). Below the IPN description, you must also enter in a URL for where PayPal should POST the order information. You will want to point this to one of the modules included with Miva Merchant, called paypalp.mvc. A standard URL will look like this:


Once the changes have been made, click on the Save button. You will be taken back to the initial Preferences screen. Confirm that IPN says ON next to it and that the URL is correct. If they are, you may logout of your PayPal manager.

You’re all done!

04-27-2006, 04:40 PM
Thanks for the reply and Info. I will look at this tonight.