PDA

View Full Version : FFMPEG Support



jbiljr
02-20-2006, 09:50 PM
I have, for the past 24 hours, been attempting to compile FFMPEG with out avail. I understand that WestHost Techs. are not able to help with third party software all of the time but this is getting a bit nutty.

I have been on the tech support phone line 3 times today and there has been no help. I have been to what I believe is every FFMPEG site on the net and I am guessing that the reason I am having such a problem is because of environment issues.

If anybody at WestHost can tell me if it is possible to run or compile FFMPEG successfully on a WestHost VPS, it would be greatly apprecaiated. I have tried everything and cannot get it to work.

If you can also include FFMPEG in your application package it would be even better for the future. All I ask for the time being is if I can use it or not so I can stop pulling out my hair trying to figure out what is wrong.

Thanks,

John Bilotta Jr

jbiljr
02-21-2006, 10:10 AM
I have gotten a little further in the FFMPEG arena just to find that the '/usr/local/bin/' permissions cannot be changed and that is blocking the installation of FFMPEG. This is really annoying given the fact that this directory is used for many user installed applications.

blender
02-21-2006, 10:41 AM
I'm not sure why it would need to change the premissions on the /usr/local/bin/ directory but it should be able to create files inside that directory without any problem. But I guess if it is complaining about it then maybe you could try to use the "./configure --prefix" option to tell ffmpeg to install to a custom location so that you don't run in to permissions problems. Something like this should work:

./configure --prefix=/usr/local/ffmpeg

good luck.

wildjokerdesign
02-21-2006, 10:48 AM
Matt has had quite a bit of success with installing things. He has a page set up that details some things he has been able to install. http://www.domsch.com/westhost/ perhaps that would be of some help. I know he has installed things into /usr/local

wildjokerdesign
02-21-2006, 10:53 AM
Ahh... I see blender beat me to it. :) It may still be of use to you to check Matt's page. He also mentions installing things in /home/username directory on some things. He details when he ran in to trouble on things and what he did to get around them. Perhaps one of those will apply in this case.

jbiljr
02-21-2006, 11:59 AM
Well thank you both for responding and your suggestion did the trick blender! Still, I cannot get Gallery2 to recognize the ffmpeg binary. I keep getting error codes, and it is driving me nuts.

I know it is the correct binary, and I know that it installed correctly, it just won't work.

I do not know what else to do.

jbiljr
02-21-2006, 12:10 PM
I may have found the problem. Apparently FFMPEG is looking for GLIBC_2.3 and it is not finding it. It may be someting that West Host does not support.

jbiljr
02-21-2006, 02:57 PM
I keep hitting walls with this. The WestHost boys are telling me that the GLIBC is 2.9.x so FFMPEG should be working. I cannot find the reasion why. Everytime i take a step forward with it there seems to be something else that obstructs the progress.

Gallery2.0.2 keeps telling me that the Binary I built is not a valid binary. I swear on my mother I have dotted every "i" and crossed every "t" and this is not working. I have been around the net and back and others seem to be using FFMPEG on other hosts without a problem.

If anyone knows how to fix this problem, please by all means let me know.

wildjokerdesign
02-22-2006, 08:09 AM
I don't know if you visited Matt's page or not but under his details of ImageMagick he mentions that he installed it in /home/username and that he hadto also make sure that was in /ect/ld.so.conf file and that he ran ldconfig after he finnished his install. I am just graspeing at straws but I wonder if that is relevant in this instance.

blender
02-22-2006, 09:12 AM
The WestHost boys are telling me that the GLIBC is 2.9.x so FFMPEG should be working.

I'm not so sure about this, according to this link the most recent version is 2.3.6:
http://www.gnu.org/software/libc/libc.html

I don't remember for sure which version of glibc WH is running (2.1.x or 2.2.x) but from my experience I don't think they are running 2.3, so that may indeed be causing your problem with ffmpeg.

jbiljr
02-22-2006, 12:16 PM
You are so right blender. I neglected to check the GNU site. I guess the tech helping me was just a little confused.

I just got off of the phone with WH with some suprising news. Apparently West Host is not running GLIBC_2.3.x and cannot at this time, run it. They even said that they are not prepared to migrate to this latest library and it would seem, are a couple of generations behind. I find this a bit disheartening given the fact they are a hosting company that is not up to date with a development environment which changes as much as a Victoria Secret model changes underwear.

It would appear that I have to build and compile my own GLIBC's and see if that solves the problem. At the moment WH is unable to update them for me.

slashx
02-24-2006, 10:47 PM
i can't even get ffmpeg to compile. one of the .h files cant include the /boot/kernel.h include file. its not found.

grab.c
In file included from /usr/include/linux/version.h:1,
from /usr/include/linux/videodev.h:5,
from grab.c:26:
/usr/include/linux/rhconfig.h:13:26: /boot/kernel.h: No such file or directory

any help would be appreciated.

jeff

jbiljr
02-25-2006, 10:33 AM
Here is the thing. You have to compile FFMPEG by using a prefix argument in your configure command like this.

"./configure --prefix=/usr/local/ffmpeg"

You have to do this because the West Host VPS will not allow you to install directly into the the usr/local/bin directory.

If you get that far you will run into another problem. In order for FFMPEG to run it needs GCLIB-2.3 or higher. West Host does not have these and if you attempt to install the libraries it will fail because West Host again does not have the right version of the GCC compiler. You can not load the correct GCC compiler version because you need GCLIB-2.3 or higher. It is a chicken and egg issue.

I spent a good 5-6 hours one night finding all of these problems and re-writting the virtual /proc files. Nothing will work because West Host's VPS is very crippled when it comes to LINUX software. They say that you can load anything and have complete control of your server, however, their architecture is a bit dated. I should say that their VPS technology seems to be very dated, it acts like a barebones version of Red Hat Linux Enterprise 7 .

To make this long post even longer.... The bottom line is FFMPEG cannot be used on West Host servers. They seem to not have any desire to get it to work. It is regretable because I am getting the feeling that WestHost is a bit behind the times when it comes to development.

slashx
02-25-2006, 03:14 PM
since i can't get ffmpeg installed are there any workarounds to submitting videos (with thumbnails) to gallery.

jeff

Evose
05-14-2006, 06:04 PM
Step 1: Download Source to /usr/local
http://prdownloads.sourceforge.net/ffmpeg/ffmpeg-0.4.9-pre1.tar.gz

Step 2: Extract Soure
tar -zxvf ffmpeg-0.4.0-pre1

Step 3: Symlink /boot/kernel.h
Submit a trouble ticket and ask them the create a symlink called /boot/kernel.h pointing to /boot/kernel.h-2.4.9. This will fix the compiling error you were getting for the missing kernel.h file.

Step 4: Install
./configure --prefix=/usr/local/ffmpeg
make
make install

Step 5: Active Module
Path to FFMPEG is /usr/local/ffmpeg/bin/ffmpeg

jhenderson
06-17-2006, 06:48 PM
What evose suggested works! However, I still want to have the ability to include the "lame" library and a couple of other items working so that I can convert quicktime files to flv videos with the sound working. Has anybody been able to accomplish this yet on the westhost servers? In addition, has anybody been able to get ffmpeg-php to work on westhost servers? Please let me know, it would be much appreciated! -James

pglatz
10-12-2006, 09:18 PM
I followed the instructions Evose posted (thanks!) and got it to make and install, and it works standalone. But with Gallery2, I get the following chain of errors:
Error (ERROR_BAD_PATH)
* in modules/core/classes/GalleryDataItem.class at line 129 (GalleryStatus::error)
* in modules/core/classes/GalleryUnknownItem.class at line 77 (GalleryDataItem_core::create)
* in modules/core/classes/helpers/GalleryItemHelper_medium.class at line 203 (GalleryUnknownItem_core::create)
* in modules/core/classes/GalleryCoreApi.class at line 1499 (GalleryItemHelper_medium::addItemToAlbum)
* in modules/core/ItemAddFromBrowser.inc at line 89 (GalleryCoreApi::addItemToAlbum)
* in modules/core/ItemAdd.inc at line 94 (ItemAddFromBrowser::handleRequest)
* in main.php at line 174 (ItemAddController::handleRequest)
* in main.php at line 87
* in main.php at line 80

I saw a comment that ERROR_BAD_PATH may be related to an incorect /tmp path, but I don't see anywhere to specify that.

Has anyone gotten ffmpeg and Gallery2 to work together? Any suggestions?

jeffklann.com
01-27-2007, 12:05 PM
I followed Evose's helpful instructions and now get the following error during make:

gcc: Internal error: Segmentation fault (program cc1)
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[1]: *** [i386/dsputil_mmx.o] Error 1
make[1]: Leaving directory `/work/ffmpeg/ffmpeg-checkout-2007-01-25/libavcodec'
make: *** [lib] Error 2

Can anyone help?

erikdevries
02-02-2007, 05:08 PM
I don't have a working solution for compiling ffmpeg yourself. I did however find a pre-compiled binairy of ffmpeg, that works without any problems.

You can find some more information about it on the following forum: http://gallery.menalto.com/node/51420 and I tried the binary inside: http://www.mikeserv.org/files/ffmpeg_glibc22.zip

I don't know what is and what isn't included in this build, but it does what I want it to do (and that is extract a jpeg frame from flv video files).

LWC
04-27-2007, 12:39 PM
I've wanted to use ffmpeg for Geeklog's Media Gallery and found this topic.

That file inside the ZIP archive works perfectly with MG (it uses it to create thumbnails for video files)...except WMV3+ files, to which it calls an "unsupported codec". Or maybe is it a general ffmpeg issue?

sergei
06-11-2008, 05:31 PM
Does anyone have anymore insight into ffmpeg on WestHost servers? This is very important to me too. Please, if someone has more information or successes, please share. Let's stay active here on the forums and help each other, not keep knowledge to ourselves. And please, let's put pressure on WestHost to make this a standard installation on the servers/VPS'.

dattas
06-11-2008, 09:18 PM
Installing FFmpeg was very easy, all I did was (make sure you have GNU installed within Site Manager):

Directions moved to here (http://forums.westhost.com/showthread.php?t=11558)

It took me less than 5 minutes to install on my account. 3.0 is an awesome upgrade from 2.0.....
Also there is not nearly enough demand for it if you look, this and most other posts are over a year old. FFmpeg is just too easy to install IMHO.

aberg
07-18-2008, 01:40 PM
Installing FFmpeg was very easy, all I did was (make sure you have GNU installed within Site Manager):
1) wget http://ffmpeg.mplayerhq.hu/ffmpeg-export-snapshot.tar.bz2
2) tar -jxvf ffmpeg-export-snapshot.tar.bz2
3) cd ffmpeg-export-*
4) ./configure --prefix=/usr/local/ffmepg
5) make && make install

It is really that easy, you can also do this to make programs find it easier
6) cd /usr/local/bin
7) ln -s /usr/local/ffmepg/bin/ffmpeg
8) ln -s /usr/local/ffmpeg/bin/ffserver

It took me less than 5 minutes to install on my account. 3.0 is an awesome upgrade from 2.0.....
Also there is not nearly enough demand for it if you look, this and most other posts are over a year old. FFmpeg is just too easy to install IMHO.

Thanks for this.
Only one question.
After step 7 I get the messages:
In: command not found
Can you please tell me what I do wrong?

dattas
07-19-2008, 08:53 AM
aberg,
it is L (lower case) not I
that is why you are getting an invalid command

aberg
07-19-2008, 01:09 PM
Thanks but I get now this error:

Ln: command not found

I have try this from the shell command:

ffmpeg -version
Also I get the command not found

It's seems not so easy to make it work.
Please do you have more idea's?

mtinker
07-19-2008, 03:52 PM
4) ./configure --prefix=/usr/local/ffmepg


typo in step 4, should be
./configure --prefix=/usr/local/ffmpeg

dattas
07-19-2008, 05:36 PM
for shell commands, they are case sensitive, all of my commands are copy and paste, please do so or else you will get a command not found. Thanks for finding the mistake, I always make that, it has been fixed on the real version that is posted Here (http://forums.westhost.com/showthread.php?t=11558)
If you want it to show up when you are just in any folder, you must make the symlinks (via the ln command)

aberg
07-20-2008, 08:44 AM
Thanks,this is maybe one of the isue I have make.
I have done now all steps and it seems te be good because there where no errors detect now.
But still when I go to shell and type ffmpeg -version I get the message: command not found
I also have try to uploading a video but the screens are emty and no file is uploaded in de directory from the programm.

The support answer me:

But if you get this in shell:
ffmpeg -version
No command found.

then it is not installed...

No errors now but still problems.
Are there more steps what I must do?

dattas
07-20-2008, 10:01 AM
Did you make sure to cd to /usr/local/bin before using the ln command? you need to create those symlinks in that directory, as a alternative you can use these commands:

ln -s /usr/local/ffmpeg/bin/ffmpeg /usr/local/bin/ffmpeg
ln -s /usr/local/ffmpeg/bin/ffserver /usr/local/bin/ffserver

aberg
07-20-2008, 11:23 AM
Yes,I have done that step.
I have done your instructions:

ln -s /usr/local/ffmpeg/bin/ffmpeg /usr/local/bin/ffmpeg
ln: `/usr/local/bin/ffmpeg': File exists

ln -s /usr/local/ffmpeg/bin/ffserver /usr/local/bin/ffserver
ln: `/usr/local/bin/ffserver': File exists

But when I use this command:
ffmpeg -version
-sh: ffmpeg: command not found

Maybe something in the php.ini file changing?

dattas
07-20-2008, 11:33 AM
I bet you copied and pasted the wrong --prefix path. try this:

cd /usr/local/bin
mv ffmepg ffmpeg

and try to do ffmpeg -v

aberg
07-20-2008, 01:40 PM
Try that:

cd /usr/local/bin
mv ffmepg ffmpeg
mv: cannot stat `ffmepg': No such file or directory

and try to do ffmpeg -v

[/usr/local/bin]$ ffmpeg -v
-sh: ffmpeg: command not found

I included a screendump from the server.
I don't see a file ffmpeg but there is a map ffmpeg.
Maybe there is missing a link in this folder?

dattas
07-20-2008, 01:45 PM
looks good to me, execute this:

echo $PATH

and let me know the results

aberg
07-21-2008, 10:59 AM
echo $PATH

/usr/kerberos/bin:/bin:/usr/bin:/usr/local/bin:/sbin:/usr/sbin:/usr/local/apache/bin

dattas
07-21-2008, 12:16 PM
well, just by looking at it, it should be working. If you want I can fix it, PM me your domain and Site Manager username and password. After I am done you will want to change your Site Manager password again. If you are not willing to provide this information (I don't blame you) then I don't know how much more help I can be because based on the information you have given me, everything should be working.

aberg
07-21-2008, 02:01 PM
After send I PM to dattas he has solved the problem immediate.
That's what I call great help and support.
Compliments and appreciation for him.
Thank you dattas

dattas
07-21-2008, 02:10 PM
its my pleasure, I love linux and I don't mind helping people at all. Maybe I can get WestHost to hire me, hehe, I don't think they would go for that, but here is hoping, maybe if I help enough people in the forums. If you need any further help, let me know.

socomusic
07-21-2008, 11:14 PM
Just for reference what was the problem?

dattas
07-22-2008, 11:04 AM
He had his symlinks pointing to /usr/local/ffmpeg/ffmpeg instead of /usr/local/ffmpeg/bin/ffmpeg, an easy mistake to make

frankcoder
04-12-2010, 02:10 PM
Does anyone know how to install ffmpeg-devel?
Thanks,
Frank

wildjokerdesign
04-16-2010, 02:41 PM
Pretty much the same proceedure as the above. You download and go through the process. It is really hard to get going on a WH 3.0 account. You might have better luck over at vps.net where you have true root access, and in fact they even have an image for ffmpeg that you can load up.