PDA

View Full Version : Mive email / order completion major error



proaudiogear4less
09-21-2005, 12:38 PM
Since the upgrade from 4.24 to miva 5 I ahve just become aware of a serious problem. Whenever any client tries to checkout and complete the order, miva returns the following error "miva failed to read smtp status". I have tried setting the mail server in miva config to "mail.domainname.com", "domainmane.com", "www.domainmanme.com", "localhost", "mail.localhost.com", "mail.localhost" as well as the ip address of our westhost mail server. It was suggested that maybe we should try our ISP mail server, which i also tried with no luck. We did have some issue with our isp blocking port 25 about 6-8 months ago (we couldn't send any mail for almost a week) but that was resolved and the port 25 block removed. If I put in any mail server info that i know is wrong or we have no access to miva gives the error "cannot connect, cannot find or connection refused. If I use what our mail server actually is or any variations on it (www. , mail. etc..) it continues to report "miva failed to read smtp status". I have even tried just disabling the customer and admin emial notification but then when check out is completed, the page doesn't redirect or anything the page is just black, hitting refresh says the basket is empty. This wasn;t an issue before the miva 4.24 to 5 upgrade. However, I tried to purchase something form the old site an dit displays the confirmation page but the top of the page displays this error on the old miva 4.24 store "Runtime error in ouisub4.mvc @ [00000081:00000234]: Line 3316: MvSMTP: Failed to read SMTP status: Runtime error in ouisub4.mvc @ [00000083:00000364]: Line 3316: MvSMTP: Failed to read SMTP status". This obviously has been an issue since the upgrade but I wasn;t made aware of it until last night and I have been doing trouble tickets, phone calls and vchat supports calls for this since and no one has any idea at this time what the problem is. What really sucks is we have been doing google adwords advertising and I get calls every 15 minutes for sales, and most of them are complaining that they couldn't order online. I'm at a loss and have had nothing but headaches with the miva 5 upgrade. Many items weren;t imported, many items descriptions (headers/footers) weren;t imported (even though they weren't in the openui fields for that) and I have been having to have westhost bandage up every corner to make things work. I'm wishing at this point I would have stayed with the previous version and left well enough alone. ANY help or suggestions are greatly appreciated. Every few minutes that pass is another sale lost and a potential customer that is dissapointed by the lack of functionality and probably will not return to make future purchases.

proaudiogear4less
09-21-2005, 01:25 PM
Now I have tried unchecking the customer email notification, merchant email notification, removed the authorize.net payment and just enabled check and simple credit card verification. Then i reactivated the customer and merchant email, set the mail server to the same mail.domainname.com that worked before the upgrade.... Now whenever a customer tries to check it it just copmes up with a blank page. This really sucks. Why did I upgrade to Miva 5?
Any help is appreciated.

jmh
09-25-2005, 09:32 AM
Now I have tried unchecking the customer email notification, merchant email notification, removed the authorize.net payment and just enabled check and simple credit card verification. Then i reactivated the customer and merchant email, set the mail server to the same mail.domainname.com that worked before the upgrade.... Now whenever a customer tries to check it it just copmes up with a blank page. This really sucks. Why did I upgrade to Miva 5?
Any help is appreciated.

Yes, why did you upgrade to MM5? Anyhow, did you contact your host? They should be able to give you the correct setting for emails.

proaudiogear4less
10-05-2005, 04:33 PM
Because it uses mysql for the database, and I pretty much figured a newer version would be more optimized for speed and search engine spidering.
After getting comfortable with the new admin interface, I do like it better and pages seem to load faster.

kimalpena
10-30-2005, 07:07 PM
the host company is still trying to figure the error, also went back to the v4 store and it also has errors now after upgrade. I have started to look for new host and shopping cart.

rispku
11-02-2005, 05:00 AM
Could this be a problem with the upgrade process? Have either of you tried uninstalling both versions and reinstalling Merchant 5 to see if the problem disappears?