PDA

View Full Version : Westhost and Movable Type 3.2



DashHouse
09-01-2005, 08:18 AM
For the past week, I've been trying to install Movable Type 3.2 on my VPS with Westhost. The previous version ran fine. The upgrade has been a bear.

This seems strange to me. I'm sure I'm not the only person trying to use a current version of Movable Type on Westhost. It's frustrating that it's so difficult. I've requested a custom install of some perl modules - at a pretty significant charge - from Westhost (https://corp.westhost.com/customservices/) but haven't heard back yet after 3+ days.

Here's the problem:

I ran the mt-check.cgi script and it says that I am missing DBI:
DBI (version >= 1.21)
Either your server does not have DBI installed, the version that is installed is too old, or DBI requires another module that is not installed. DBI is required if you want to use any of the SQL database drivers. Please consult the installation instructions for help in installing DBI.

Fine. I'm not the only person who's needed this module. The problem is that I've tried everything I can think of to update DBI, using CPAN. Some good guidance in this thread in the MT forums:
http://www.movabletype.org/support/index.php?act=ST&f=26&t=54133&hl=unsupported+driver&

Even installing an older version of the DBI module doesn't seem to work.

At this point I don't know what to do. Custom services doesn't seem to respond and I've tried absolutely everything I can think of.

I can't be alone in this, but it's driving me crazy. Anybody out there? I'd sure appreciate some type of help!

MacToph
09-14-2005, 10:13 PM
DashHouse-
I feel your pain- I tried to upgrade my existing Movable Type installation only to discover later that WH is still running DBI version 1.13 and support has told me that "DBI v1.14 and above(as far as I am aware) require at least perl v5.6.1

and WH is currently running v5.6.0- this all seems really ridiculous to me, especially considering that Movable Type is such a popular application.

Can anyone verify what I have been told by WH? Or does anyone have instructions on upgrading Perl so that DBI v1.21 (or later- it is now at v1.48). WH is in the process of upgrading to Perl 5.7.8 and are giving an estimate of November, so it will be at least a couple of months away.

Any interim solutions or ideas anyone has for someone who wants to use WH?

(As an FYI- the current version of DBI available on WH, v1.13 was released on 11th July 1999- ridiculous)

Thanks

Cheddarmakerman
09-15-2005, 08:16 AM
You could sign up for the Perl Beta release:

http://forums.westhost.com/showthread.php?t=8469

MacToph
09-16-2005, 12:01 PM
That's a good thought Scott- I decided to pass on the beta for a couple of reasons:
1- I don't know Perl that well to be very helpful and
2-The Beta testing isn't done on your actual server, they set up a second account for you to test on and they won't install the application on your actual server until 2-7 days before mass deployment....


You could sign up for the Perl Beta release:

http://forums.westhost.com/showthread.php?t=8469

richfavinger
01-07-2006, 03:26 PM
Have a go at:
http://codeworks.gnomedia.com/westhost-introduction/
And how to go about using Perl...

SOME Perl mods can simply be installed by CPAN via SSH.

WordPress is a great alt' to MT. Templates are simple too. And now WordPress 2.0 is out, you can install WP2 in all of about 3 min.
:)
Many MT admins have come over to WP, as you seem to already know MT is still a PITA.