PDA

View Full Version : Easypopulate and Zen Cart aka modded OSCommerce



maida
06-12-2005, 12:30 AM
Has anyone had any experience with Easypopulate v2.75 and Zen Cart 1.2.4?

I consider myself pretty handy with installing scripts and mods (YaBB, Wordpress and Zen Cart installs have gone successfully), but Easypopulate has me stumped.

To test it, I entered 3 items into the product catalog through the admin of Zen Cart.

I used Easypopulate to export the products

I opened the exported file in Excel and changed the price on one product

I saved the file as tab-delimited

I use Easypopulate to import the file.

It looks successful (no error messages)

The price does not change. If I export the file again, it is the original file before I changed it.

UGH.

Any ideas?

Maida

Tom Howard
06-22-2005, 10:31 PM
I've had problems with editing exported files in Excel. For instance, I've opened csv files in Excel and then saved (exported) under another name without making any changes at all. I've then run diff (a utility to find differences in files) and found that Excel had altered the original.

If I remember correctly, easypopulate won't make any changes when it imports if there is any kind of problem when it imports (like unexpected characters or a bad file format).

My recommendations would be to try exporting as a comma separated file instead of tab separated file or to try editing the file with a simple test editor (like notepad) instead of Excel. See if it makes a difference.

maida
09-05-2005, 03:49 PM
Turns out my problem all along was that most versions of the script are not compatible
with PHP 5.

Looks like a new person took over maintaining the script in the middle of its history and, so far, the PHP 5 version is only available at this site: ftp://portability.dnsalias.com/EP_v1.2.5.1.zip

Hope that helps someone!

Maida

Ron_D
09-13-2005, 07:09 PM
Can anyone walk me through installing EasyPopulate on the default install of osCommerce? I've read the text file, 1readmeFIRST, that came with EasyPopulate, but to no success.

Please help,
Ron_D

maida
10-18-2005, 09:09 PM
Turns out my problem was an incompatibility issue with the scripting and the version of PHP we had installed...