PDA

View Full Version : News::NNTPClient ?



RexSwain
05-29-2005, 05:05 PM
In perl, I'm trying to

use News::NNTPClient;

but I'm getting the error message

Can't locate News/NNTPClient.pm in @INC (@INC contains: /usr/local/perl/lib/5.6.0/i686-linux /usr/local/perl/lib/5.6.0 /usr/local/perl/lib/site_perl/5.6.0/i686-linux /usr/local/perl/lib/site_perl/5.6.0 /usr/local/perl/lib/site_perl .) at ./news.cgi line 9.

Can anyone suggest a solution?

wildjokerdesign
05-29-2005, 09:38 PM
Looks like you would need to install NNTPClient. Below is a link to the info on the specific News::NNTPClient and on the right at the top is the down load link.
http://search.cpan.org/~rva/NNTPClient-0.37/NNTPClient.pm

Have a look at this thread and scroll down to JohnnyBoy's reply.
http://forums.westhost.com/phpBB2/viewtopic.php?t=3051

It may give you and idea of how to install it. This is not my area. :)

jalal
05-30-2005, 01:31 AM
You should be able to install it with CPAN.

In SSH type:
$ cpan
> i News::NNTPClient

RexSwain
05-30-2005, 06:31 AM
Thank you both. The CPAN technique did not work for me (perhaps I initialized cpan incorrectly). But installing NNTPClient with the wget/tar/make recipe worked fine. Thanks again.