View Full Version : WestHost moved my server and changed httpd.conf settings

05-11-2005, 12:10 PM
On 03/31/2005 WestHost moved my server to another machine and changed my httpd.conf settings. The following settings are what concern me the most...

# It does this by periodically checking how many servers are waiting
# for a request. If there are fewer than MinSpareServers, it creates
# a new spare. If there are more than MaxSpareServers, some of the
# spares die off. The default values are probably OK for most sites.
#MinSpareServers 5
MinSpareServers 1
#MaxSpareServers 20
MaxSpareServers 1

# Number of servers to start initially --- should be a reasonable ballpark
# figure.
#StartServers 8
StartServers 1

# Limit on total number of servers running, i.e., limit on the number
# of clients who can simultaneously connect --- if this limit is ever
# reached, clients will be LOCKED OUT, so it should NOT BE SET TOO LOW.
# It is intended mainly as a brake to keep a runaway server from taking
# the system with it as it spirals down...
#MaxClients 150
MaxClients 15

Does anyone know what the default settings for these variables should be? Ever since WestHost changed these settings my site has been sluggish, and I keep getting the following error in my error logs:

server reached MaxClients setting, consider raising the MaxClients setting

I'm dissapointed that they changed these settings without notifying me, and I am really suprised that they expect a max of 15 clients on a commercial retail site.

Zest Gourmet

05-11-2005, 11:08 PM
I think 15 is the norm that they rund most accounts at. I do have one running at 20 but most of mine seem to be fine at 15. I can't remember the math of it but 15 actually lets more people view your site at a given time then you would think. Haveing it set at 15 was high enough to let me watch the bandwidth on one of my sites climb quite high in just an hour when back during one of the phpBB attacks and the board actually was showing way more folks on then I ever get.

05-12-2005, 07:49 AM
My MaxSpareServers is set to 3. Everything else is the same.

05-12-2005, 12:41 PM
Thanks to both of you for your responses! That puts my mind at ease.

I was having problems with the clients maxing out, because my site traffic gets pretty busy at times. However, I contacted support and they increased the max client setting for me.