PDA

View Full Version : ZendOptimizer



nsc
02-22-2005, 03:46 PM
Hi,

after an upgrade to php4.3.10 I noticed I had no Zend Optimiser so I tried to install it.

I downloaded Zend Optimiser 2.5.7 and I edited the installation script to allow me run it (it checks whether the user is root, if it isn't it exits, very stupid).

I ran the script and I was just pressing Enter in every question it asked. I ended up with a message saying it was not installed. It had problem with directory permissions. So I runned it again

In the second execution, I instructed it to install itself to a Zend2 directory. The installation was successful.

It outputted to me this message:



The following configuration changes have been made:
- The php.ini file has been relocated from /usr/local/lib/../../lib to /usr/local/Zend2/etc.
- A symbolic link for the php.ini file has been created in /usr/local/lib/../../lib.
- The original php.ini was backed up to /usr/local/lib/../../lib/php.ini-zend_optimizer.bak


It asked me to restart Apache, so I did it.

The problems:

when I call phpinfo(), I see no mention of Zend Optimiser!

In php.ini, the safe mode setting is Off, but in phpinfo() it says it is On!

My site seems to work correctly at first sight, but I don't think that Zend was installed correctly. What do I need to do now? How can I ensure that Zend is installed and what should I do about the safe mode?

Armadillo
02-22-2005, 08:18 PM
Restart via site manager, then check the phpinfo.
It should have Zend Optimizer config info.

To get safe mode off, make a copy of your optimized php.ini.
Uninstall PHP.
Reinstall PHP.
Replace the php.ini with the optimized one you made a copy of. It may be in several locations.

Restart via the site manger.

nsc
02-22-2005, 08:34 PM
Hi,

I just solved my problem, thank you very much!