PDA

View Full Version : PHP upgrade... you might want to hold off...



wildjokerdesign
02-01-2005, 04:27 PM
Well I was so happy to see the Upgrade to php in my Site Manager. I went to the instructions on what to do to upgrade that are mentioned up in the Anouncements and followed them. Upgradeing other php programs and then un-installing the old version and installing version 4.3.10.

Seems there is a bug and it shut down apache. I was unable to restart Apache and contacted support. They had to comment out some lines in the httpd.conf to get Apache to restart and then I had to log back in and remove the new version and re-install the old one. They then went back in and uncommented the lines that where the problem and again restarted Apache to get things back up and running as before. For those who understand the problem is with
<IfDefine HAVE_PHP4>
LoadModule php4_module modules/libphp4.so
</IfDefine>and
<IfDefine HAVE_PHP4>
AddModule mod_php4.c
</IfDefine>

They don't have a timeline on when they can get this fixed and I am not even really sure it would effect all intallations. If you do find yourself in this fix you need to get in contact with tech support and have them help you get things back up and running.

sunzon
02-01-2005, 04:33 PM
Me too, problems.

Didn't get as far as testing much because I got stuck recreating a database for mysql.



Perl - MySQL libs test


DBI using mysql libs

Connecting Database 'test' failed: DBI->connect failed: Client does not support authentication protocol requested by server; consider upgrading MySQL client at /var/www/cgi-bin/plugins/PerlMySQLs/testql.pl line 21

Waiting on tech support, meantime my site is down... Arghh!

WildJokerDesign:
Why didn't you upgrade to 5.0.3? just curious.

wildjokerdesign
02-01-2005, 04:41 PM
The site I was upgradeing is mostly a heavily modified version of PhpBB2.0.11 and with some of them I am not sure they would work with the new version. I need to fully understand the differences and dig through the code to make sure I would be ok.

sunzon
02-01-2005, 04:52 PM
I don't use much php but thought I'd upgrade modperl anyway.
I had installed PhpBB2.0.11 here at WH but I wasn't using it yet (but I also use modified versions at another provider).
I uninstalled it anyway before upgrading to modperl 5.0.3 just to get a clean slate.
For your guidance, the re-install of PhpBB 2.0.11 failed. Not critical for me right now, but be warned!

xanzi
02-01-2005, 04:57 PM
I think I might be having the same problem as wildjokerdesign. Can't log into my site manager to check and see if Apache is down, though. Also, the link in my support email doesn't seem to be working. Sent them another one, though, telling them.

sunzon
02-01-2005, 06:08 PM
Situation update:

No response yet from Tech Support, and I can't wait too long with my site down.
I uninstalled mysql 4 and reinstalled 3.
No problems, could recreate my databases, backup and take down my message "Server temporarily unavailable" for my site visitors, because my site is back up and running :D.

So: mysql upgrade does not work, wait for a fix!

Modperl upgrade gave me no problems, even reinstall phpBB was succesful this time using the old mysql 3.

PS: Yea I know "server unavailable" sounds accusing, what I mean is "mysql server is down". Don't want to get too technical for my site visitors.

j103c
02-07-2005, 01:01 PM
I ran into the same problem as sunzon, with the:

"Client does not support authentication protocol requested by server"

This happened on a perl script and a php script. I have had to revert back to version 3 for the time being.

xanzi
02-07-2005, 03:59 PM
Any idea when MySQL 4 will work? I thought mine was working, until I realized my Wordpress installation was giving an error.

Turtlewebs
02-11-2005, 04:34 PM
Methinks I'll upgrade php (but not to 5) and leave mysql as is - surely the old version is fine and it was only php that had security holes to fix?!

wildjokerdesign
02-11-2005, 10:26 PM
Turtlewebs, That is a really good idea. I think for most users they really do not need the newer version of MySQL and many current php scripts do not work under php5. The install for upgradeing to php 4.3.10 works fine now as long as you follow the guidelines that WH supplied links to in their announcement. Pretty painless at this point.

fixed version number

jalal
02-12-2005, 04:44 AM
Wise move Turtlewebs.

I can't think of any reason for upgrading MySQL, unless you are specifically writing scripts to make use of the new features. Otherwise the old version is faster and safer.

cjjibble
02-12-2005, 04:57 AM
Having read that the Zend optimiser isn't included with the new php version, I don't really want to upgrade php and find that all my scripts run at half the speed that they used to. Are there any plans to sort this out?

xanzi
02-12-2005, 08:19 AM
Is the new Zend optimizer not included with 4.3.10 and 5?

wildjokerdesign
02-12-2005, 08:23 AM
It is true that that Zend optimizer is not installed with the new version of php but it does not seem to have effected any of my php scripts and one of my sites is heavy php. If anything seems a bit smoother.

There are some security issues that upgradeing takes care of so it really is a good idea to upgrade. Most every site you visit that offers scripts and maintians them now suggest that you upgrade to at least the 4.3.10 version.

coppercup
02-12-2005, 01:28 PM
The reason for the MySQL error mentioned above is that the PHP 4.3.10 upgrade installation is not recognizing the MySQL 4 upgrade, and it is compiling with the 3.23.x MySQL client API, which won't work properly with MySQL 4.1-and-higher's new password authentication scheme.

I found this workaround:
http://www.whoopis.com/howtos/mysql-auth-fix.html

I have tried it, and it works. You have to log in to your shell account, log into the mysql command line, then set the password according to the instructions.

Regarding Zend, my PHP 4.3.10 installation is showing that Zend is installed, according to a phpinfo() script.

Armadillo
02-12-2005, 03:42 PM
Regarding Zend, my PHP 4.3.10 installation is showing that Zend is installed, according to a phpinfo() script.

It has the "Zend engine" but not the Zend Optimizer.
If you look on an old phpinfo page there was a whole config section for the Optimizer. There is none in the new phpinfo.

I have confirmed with WH support that the Optimizer is not installed.

My php is using the wrong mysql client but the password works as long as I connect as root.

Armadillo
02-12-2005, 10:35 PM
I installed Zend Optimizer following Blender and Burks instructions.
I works, but I had a few problems.

After restarting via the install script the Optimizer was not running. I had to restart via the Site Manager.
Afterward safe mode was on, so I reinstalled php and replaced the php.ini with the optimized php.ini per Burks instructions.
It worked, but I could no longer FTP to my site.

I restarted again, and now it's functioning.

j103c
02-13-2005, 12:48 PM
The page wouldn't pull up for me, but I got it out of the Google cache:


MySQL 4.1 and up uses an authentication protocol based on a password hashing algorithm that is incompatible with that used by older clients. If you upgrade the server to 4.1, attempts to connect to it with an older client may fail with the following message:


shell> mysql
Client does not support authentication protocol requested by server; consider upgrading MySQL client

To solve this problem, you should use one of the following approaches:

* Upgrade all client programs to use a 4.1.1 or newer client library.
* When connecting to the server with a pre-4.1 client program, use an account that still has a pre-4.1-style password.
* Reset the password to pre-4.1 style for each user that needs to use a pre-4.1 client program. This can be done using the SET PASSWORD statement and the OLD_PASSWORD() function:


mysql> SET PASSWORD FOR
-> ' some_user '@' some_host ' = OLD_PASSWORD(' newpwd ');

It still seems to me that WestHost should make this an easier transition..

coppercup
02-28-2005, 09:50 AM
Important Note for beginners:

Before you can use the SET PASSWORD command to change a password from the new type to the old type, you must connect to a mysql session within the shell session.

At the prompt:

mysql -u root -p

You will be asked to enter the root user's password. Once you have a mysql session, your prompt will include:

mysql>

To exit the mysql session, just type exit and hit return.