View Full Version : apache local installation problems

01-19-2005, 03:26 PM

I got some help here regarding the installation of Apache, Php and MySQL on my windows 98 machine here. Check out this thread:


I'm suddenly facing problems now. Whenever I try to start apache I get the error:

Service "apache" is not installed!

I had some problem with my machine because of which it was restored back to its state a few months ago. All of the programs that weren't installed back then were removed from the registry, although no files were lost. So right now all of the apache files are in the right place however (I think) that the registry entries have been removed. I tried to uninstall and reinstall Apache but I always get the error that the following file is missing:


and that:

The installation source for this product is not available. Verify that the source exists and that you can access it

What do you guys make out of this?

01-21-2005, 05:14 AM

01-21-2005, 06:38 AM
When you tried to reinstall did you go and grab the apache package from their site again. I know that many installs that I do from applications it get off the web create temp files when I download them that are removed after the program installs. If you are trying to install it with a file that was left on your computer it may be looking for those files. You may need to start for square one and download apache again.

01-22-2005, 03:59 AM
I've tried redownloading Apache 3.x 3 times but it gives the same error each time. So I tried downloading 2.x and it worked. Its been installed. Anyway, I have to install php and mysql again. Where can I find instructions for modifying the config file etc? I already have Php downloaded and installed on my comp. Only need to modify the configs. Or do I have to download this stuff again?

01-22-2005, 04:34 AM
I've added these lines to the end of the httpd.conf file:

LoadModule php4_module f:/php/sapi/php4apache.dll
AddModule mod_php4.c
AddType application/x-httpd-php .php

but whenever I try to run apache I get an error that looks like this:

Syntax error on line 965 of C:/blablabla/httpd.conf:

Cannot load C:/php/sapi/php4apache.dll into server: one of the library files needed to run this application cannot be found

(p.s i'm not copying and pasting the error , i've tried to memorized the error and i'm typing what i remember the way i remember it)

So anyone got a solution to this problem for me?

01-22-2005, 05:06 PM
Make sure the path is correct. You said you typed it in from memory, so maybe that's why you're trying to load from the F: drive in the httpd.conf file and the error says the C: drive. I would double check the path in the config file and the make sure that file actually does exist and is in the place where apache is looking.

01-22-2005, 06:53 PM

i've made sure that the paths are correct, but I still get the error. Also I tried to replace php4apache.dll with php4apache2.dll since I'm using Apache 2.x and an article says that php4apache2.dll is to be used with Apache 2.x but I still get the same error.

Ideas anyone?

01-24-2005, 12:50 AM
so no one knows the solution to this? :shock:

01-24-2005, 06:45 PM
Judging by your httpd.conf extract you have installed php on the F: drive and apache is looking for it on the C: drive, judging by the error message you give.

What i suspect is wrong is that apache is not reading the F: portion of the file specifier, and looking for the module on the same drive as apache is installed on. A quick and possible solution would be move your php folder from the F: to the C: drive then see if apache will see the file, it should do.

If that works or if you want to try something else, you could try putting a / in front of the F: in your httpd.conf file. This may help. It tells apache to goto the root of all file systems, and then treat your drives as subdirectories off the root. I think this is how apache deals with Windows seperated file systems any way. I may be confused with Cygwin, but give it a go any way. If this works, then you should be able to run apache from C: and php from F:

hope it works :)


03-06-2005, 05:36 AM
Ok guys, heres the deal. I couldn't get php to work that time, so now I have reformated my hard drive, re installed windows, re installed everything from scratch, and installed Apache and Php again. This time Apache 1.3.33 and Php 4.3.0, and still on windows 98. Well, Apache has been installed and its working fine now, but for some reason its giving the same error with php. (this time, both Apache and Php are on the same drive).

LoadModule php4_module d:\php\sapi\php4apache.dll
AddModule mod_php4.c
AddType application/x-httpd-php .php

And here is my error:

Syntax error in line 988 of d:/blablabla/httpd.conf:
Cannot load d:/php/sapi/php4apache.dll into server: (1157) One of the library files needed to run this application cannot be found:

Soo...now what??

03-06-2005, 08:03 AM
Well, it's telling you a library is missing but not which one. So I'll ask, are there any dependencies that also need to be installed. The readme file for the application you're installing will usually will tell you.