PDA

View Full Version : Help!! Looking for answers to ImageMagick error



mikeyd
12-19-2004, 06:59 AM
I am afraid I have hit a dead end. West Host does not support this app, and the Perl source code I have was purchased. I have limited knowledge of this process.

To date: I have restarted my VPS both from the West Host web page, and using Putty. Both times were after reloading using Putty and Autoget ImageMagick. The installation process using Autoget seems to be successfull using Putty. The errors I get when trying to run my app are:

/usr/bin/perl: relocation error: /usr/local/perl/lib/site_perl/5.6.0/i686-linux/auto/Image/Magick/Magick.so: undefined symbol: perl_get_sv
[Sun Dec 19 06:40:52 2004] [error] [client 65.29.74.91] Premature end of script headers: /var/www/cgi-bin/auction/yourphoto.pl

I talked to the author of my Perl script, he sais his script is working perfectly with other host, and most likely 1) not setup correctly on your hosting server 2) the path to imagemagic they gave you is not correct.

I have seen similar errors on google and on this forum, but no clear explanations for the "relocation error"

Thanks
MikeyD

REC-WH
12-19-2004, 08:26 AM
I would like to see a reply from WH about this problem! I have a perl script which uses ImageMagick and I get a "blank page" when it tries to generate thumbnails. I have read that there is a "6 sec" time which is common for most hosts to use to limit CPU useage which causes problems with ImageMagick.

I don't know if all the required perl scripts are installed. I am not a programmer so I am lost.

I think WH should reply with a "Final Answer" about this script. I think we deserve an answer to this on going problem.

Where are you WH!

CM

mikeyd
12-19-2004, 02:26 PM
As I continue to research this topic I am finding that there are a number of hosts that do indeed support ImageMagick. I do not want to bail, but if Westhost does not have this as one of :cry: there iminent rollouts, I may be forced to look elsewhere.

Mikey D