PDA

View Full Version : Mailman Not Sending Posts



miked
09-30-2004, 04:17 PM
Ok I thought my Mailman installation was working fine, but it isn't.

When a post is sent to a list, my catch-all filter catches it and it's not sent to Mailman, or Mailman doesn't see it. I've checked the aliases (/etc/aliases) and they look fine to me.

Since there seems to be a few people that have set up Mailman successfully, I thought I would ask here. Does anyone have any ideas/suggestions?

Thanks,
-MikeD

wildjokerdesign
09-30-2004, 04:58 PM
Not sure about mailman but most scripts that send to an email must send to a real email/ftp account and not an alias account. When you set it up make sure you enable ftp at first and then if you want you can go back and disable it. This creates a home directory that some scripts and internal stuff looks at.

FZ
10-01-2004, 09:49 AM
I use Mailman with aliases, not "real accounts" - and it works fine for me. However, I do not have the catch-all enabled.

Did you run 'newaliases' after adding the aliases (ignore this if you added them via your Site Manager)? Are the paths correct? Are the Mailman processes running?

miked
10-01-2004, 04:31 PM
I did run newaliases. The paths appear to be correct.

The Mailman processes are running. I can tell that because when I create a test mailing list, it sends out the creation messages and notification of subscription.

Maybe I should disable my catch-all filter?

miked
10-01-2004, 04:36 PM
Holy cow. That was my problem. All of this time I was freaking out and it was that simple.

Ok, so I'd like to be able to use catch-all filtering though. Is that a possibility through some magical alias in /etc/aliases?

FZ
10-02-2004, 07:15 AM
Interesting. It's really weird that enabling the catchall ignores your aliases set up - I think there must be something wrong there... It's not supposed to work like that. Maybe you should try contacting WestHost support.

As for checking if the processes are running, the best way to do it is to log in via SSH, and type psx and press enter. If you see a few "/usr/local/bin/py" entries (and, assuming you don't run any other Python scripts) then you have confirmed Mailman is running. If not, then you just start it up again. Alternatively, if you want to see the full process paths/names, just type ps -efl

Are your other (non-command) aliases working with your catch all enabled?

miked
10-02-2004, 11:58 AM
Yes, all of my other aliases are working fine. The catch-all alias does something weird to not allow mailman to work properly. I did run newaliases after adding the Mailman aliases too.

I'm familiar with ps. I used 'ps -ef' to see if they're running, and they are. Thanks for the info, and thank you very much for the help.

FZ
10-02-2004, 04:06 PM
You're welcome. I still think you should speak to WestHost about this. It seems there is a bug with the catch-all and command aliases.

In the mean time, what you could do (if you really, really must) is set up Procmail to manually filter catch-all mail and pipe it through to Mailman. If you do contact WestHost, let us know what they say.

FZ
10-02-2004, 04:08 PM
Hmm, it just occurred to me that the position of the catch-all in the /etc/aliases file might be the problem... Assuming it is at the top of the file (or above your Mailman aliases), perhaps moving it right to the bottom of the file and running 'newaliases' would help?

miked
10-02-2004, 07:02 PM
I was thinking the exact same thing. I couldn't immediately figure out which alias in /etc/aliases was my catch-all alias. So I re-activated my catch-all alias through the web control panel. I copied /etc/aliases to /etc/aliases.orig. Then I removed my catch-all alias through the web control panel. I did a diff between /etc/aliases and /etc/aliases.orig and there were no differences. So to me that means the catch-all filtering is done elsewhere.

I emailed tech support and they said they can't help me since Mailman is a 3rd party product and it's out of the scope of their tech support.

I can live without the catch-all alias. I'd like to have it back, but it's more important to me that Mailman works.

Thanks for your help!
-MikeD

FZ
10-02-2004, 10:53 PM
Hmm... But this is not only a Mailman issue. I understand that WestHost tech support won't help you with that - but that's not the problem here. The problem is with aliases. I think you should e-mail them back and point that out. If you (or anyone else that has time) can confirm that it is an issue with all command aliases (i.e. by trying out another non-Mailman command alias), then that's a Site Manager/VPS bug that is within tech support scope... I'd do it myself, but I don't have the time right now.

In any case, I'm glad you got it working.

miked
10-02-2004, 11:25 PM
Good point again. I reopened the ticket and told them to look into it. I said that manually adding command-oriented aliases with catch-all filtering enabled doesn't seem to be working and that they might want to look at it. I will let you know what I hear back.

FZ
10-03-2004, 07:42 AM
Cool :)

miked
10-03-2004, 12:25 PM
Ok, there's an additional step you have to do if you edit the alias entries by hand (these entries are done automatically if you use the web interface).

After you add the aliases to /etc/aliases, you have to edit /etc/mail/virtusertable and add the alias entries in this format:
maillistname@domain.com maillistname
maillistname-subscribe@domain.com maillistname-subscribe
maillistname-admin@domain.com maillistname-admin
...

It seems to "complete the circle" on the aliases for a domain. Then, when you've completed that, run:

makemap hash /etc/mail/virtusertable < /etc/mail/virtusertable

And you are good to go! I checked it out by re-enabling my catch all filter and it's working just fine!

Thanks again for all of the help!
-MikeD

FZ
10-03-2004, 01:21 PM
Great stuff. Aren't you glad I pestered you to pursue the matter? ;)

miked
10-03-2004, 03:00 PM
Absolutely. :) Thanks!

FZ
10-03-2004, 03:48 PM
No problem :D

floorbamboo
02-05-2007, 03:34 AM
Hi! I'm also trying to install Mailman 2.1.9 in our website. I'm following your post on revising virtusertable. in your statement

"makemap hash /etc/mail/virtusertable < /etc/mail/virtusertable"

is the "&lt;" equivalent to "<"?

thanks.

wildjokerdesign
02-05-2007, 07:35 AM
Yes that is correct. This is a very old thread from when we phpBB was used for the forums and in the switch some characters did not get ported over correctly. :)

floorbamboo
02-05-2007, 09:49 PM
i think i have made Mailman work. Kinda weird, though.

1. Only one Mailman should be opened in the browser, else one cannot create a list. the second window will report an "Unknown virtual host" error.

2. after creating a list through browser, i had to manually enter the settings into aliases, then issue "newaliases". then, as per your instruction, manually enter settings at virtusertable. then do the makemap.

Anyway, what matters is my Mailman is now working. Thanks, though. i wouldn't have done it without your tip.