View Full Version : Need help to setup mailman

09-27-2004, 11:34 PM
Hi all,

i have been trying to setup mailman by following the guide at:
http://www.domsch.com/westhost/ but failed.

i extracted the tarball to /mailman and followed by
./configure --with-username=myusername --with-groupname=vuser \
--prefix=/home/myusername/mailman --with-mail-gid=vuser \
--with-python=/usr/local/bin/python --with-mailhost=mydomain.com \
--with-urlhost=mydomain.com --with-cgi-gid=vuser

(FYI, i did everything from root. "myusername" was replaced with my "VDS username". Group user remains as "vuser")
and this error message pop up: "sh: ./configure: No such file or directory"

Would be grateful if someone provide me with a detail step by step guide.

Thank you.

09-28-2004, 07:11 AM
I think you would need to be in the /mailman directory. There should be a file called configure in that directory I think. Not very good in this area myself but you might give that a try.

09-28-2004, 09:28 AM
I did that both at ROOT and /MAILMAN folder. The result is the same. Same error message. What else could be the problem?


09-28-2004, 10:37 AM
Hmm... this is not my strong point. :) Is there a file configure in the /mailmain directory? If there is I wonder if you need to create the directory /home/myusername/mailman that is refrenced by --prefix=/home/myusername/mailman.

09-28-2004, 11:25 AM
I just went and grabed a tarbell of mailman when I extracted it it created a directory called mailman-2.1.5 and that is the directory that the configure file is in so look and see if that is the same with your files.

Also you need to make sure that both the GNU_Utils and Python are installed on your account. You can check this in your Site Manager under Site Applications > Development. I was reading some on the net about installing MailMan and I am pretty sure you do need to have the /home/myusername/mailman directory set up in advance.

Although this page is more detailed and for installing with both user and root permission wich you do not have here on WH you might want to take a look at it: http://sxs.thexdershome.com/internet_serving/mailman.html I would still follow Matt's instructions but it may give you some insight.

09-28-2004, 01:34 PM
Ok I went ahead and started the install on my test account and found a couple of things that need to be done.

note: in the example codes the $ is the prompt and may look different in your session. Most like it is going to look like this

[yourusername] [~]$

1.) You do need to create the directory and make sure it has the correct permissions. Below is the SSH commands to do that:

$ cd /usr/home/myusername/mailman
$ chgrp vusr .
$ chmod 2775 .
$ ls -ld

The last command should return something that looks like this:
drwxrwsr-x 2 myusername vuser 4096 Jan 3 08:47 ./

In the above you replace the myusername with your own and the in the output it is going to show up as your username and the date would be current.

2.) I then uploaded the tarbell to the root directory and then then ran this command in SSH

$ untar mailman-2.1.5.tgz

It extracted it to a directory called mailman-2.1.5 this may change if you use an older or newer version of mailman.

3.) I then ran these commands to move to the right directory and then run the configure.

$ cd mailman-2.1.5
$ ./configure --with-username=myusername --with-groupname=vuser --prefix=/usr/home/myusername/mailman --with-mail-gid=vuser --with-python=/usr/local/bin/python --with-mailhost=mydomain.com --with-urlhost=mydomain.com --with-cgi-gid=vuser

I put all the commands on one line. I know there is a way to move to the next line and I think that is what the "\" means in Matt's insturctions but I can't remember how that is done. Note that when this runs at the very end you get two errors saying that the Sort command could not be found. Don't think that matters but if you want to install sort first Jalal (http://codeworks.gnomedia.com/westhost/tips.php) has that on his site at the bottom of the page.

4.) After that I ran the make and make install.

$ make
$ make install

I decided to check the permissions like is stated in the page I gave you a link to and found that I had to also run the command to fix them. Here is how I first checked them

$ /usr/home/myusername/mailman/bin/check_perms

I recieved 56 problems so ran it again with the -f option like this:

$ /usr/home/myusername/mailman/bin/check_perms -f

I have put the full path to check_perms but if you are in the directory where it is you could leave off the path. On the insturcts it said to run it formt the mailman directory simply with "bin/check_perms".

That is pretty much as far as I went and you would still need to add the SMTPHOST='mydomain.com' to the /usr/home/myusername/mailman/Mailman/mm_cfg.py file that Matt mentions. I also think you may still need to do some of the steps that are on the instructs there are some other things it has you add to the mm_cfg.py file. I think that the info on Matt's site is just how to run the configure and such so it works with our VPS set up.

I don't plan on going on with the rest of the install but if you get stuck with something let me know and I'll try to help. The main thing to remember is you are installing in /usr/home/myusername/mailman so if the instructions are refering to /usr/local... you need to change it since we do not own that directory and can not modify it. You can access things in there for use but not change them.

09-28-2004, 11:58 PM
Hi Shawn, is that your real name? pardon me if i got it wrong.
anyway, i just followed exactly what u said and these error came out:

***** No Python interpreter found!
***** Try including the configure option
***** --with-python=/path/to/python/interpreter
./configure: sort: command not found
./configure: sort: command not found

I have checked my sitemanager--site application-- development, python is installed. I have also checked the python path, /usr/local/bin; there is a python symlink. i have also tried to change the command to :

./configure --with-username=chronologic --with-groupname=vuser --prefix=/usr/home/chronologic/mailman-2.1.5 --with-mail-gid=vuser --with-python=/usr/local/phyton --with-mailhost=chronologic.com.sg --with-urlhost=chronologic.com.sg --with-cgi-gid=vuser
checking for --with-python... /usr/local/phyton/bin

note that i changed with--python=/usr/local/phyton; because i found a phyton folder there. but that attempt also gave me same error.

argh, anyway that u can help?

thanks for trying to install it on your own test VDS in order to derive a step by step guide for me. i greatly appreciate that. Thanks a lot Shawn.

i will be waiting for your next advice.

09-29-2004, 06:36 AM
Hello vod,
Yes my name is Shawn. :)

The only thing that I see in your post that could be the problem is that you have spelled python ... phyton. Did you intend to that? I wonder if maybe you did the same thing when typeing in the command in SSH. The original path that Matt uses should be fine. /usr/local/bin/python actually leads back to /usr/local/python/bin/python. Not sure why things are set up that way but I would stick with the first one and check the spelling.

I'm assumeing that GNU_Utils are installed and that you checked that in Site Manager. I think the configure would have failed befor that if not.

If you are sure of everything and it still fails on finding Python then you may want to contact WH and ask them to check if the install is not corrupt. Do check that spelling I just misspelled it the last time I typed it in the sentence before this on. :D It only takes one letter or space to be wrong with this stuff and all fails. I misstype about eveytime I go to do something like this and even did it with I went to install Mailman this time.

09-30-2004, 10:56 PM
Hi Shawn,

The installation was too complicated. I couldnt remember whats the last error i encoutered after following your guide. anyway, i have given up mailman. Now i am using eubimiau. so far so good.

Thanks for everything.

10-01-2004, 05:49 AM
Your welcome. Sorry you where not able to get MailMan up and running but glad you where able to find and altenative and get it going.