PDA

View Full Version : Mailman doesn't send email



nsc
09-18-2004, 01:37 PM
Hi! :)

I seem to have some trouble with Mailman 2.1.5 (http://www.list.org), a Python (http://www.python.org) implementation of a mailing list manager/server.

I installed GNU compiler and Python (version 2.2.2) via the Westhost's SiteManager 2.0. Then, I followed the instructions found at Matt's Westhost Addons (http://www.domsch.com/westhost) (thanks!).

After 2-3 tries, I compiled Mailman successfully. I consulted the INSTALL and README files and set it up. I also configured correctly (I believe) the cron jobs that Mailman wants.

The configuration file of Mailman is mm_cfg.py and it can accept a setting telling it where the SMTP (Mail Transfer Agent) server lives.

My setup is:



SMTPHOST = 'wikinerds.org'


I also tried:



SMTPHOST = 'mail.wikinerds.org'


Neither works. Mailman seem unable to send email. I can access the web interface, start Mailman, subscribe emails (me), etc, but Mailman doesn't send anything.

Mailman keeps some log files. One of them is named "post" and it contains many lines that are like this one:



Sep 18 13:22:24 2004 (23519) post to mailman from mailman-admin@wikinerds.org, size=1762, message-id=<ma
ilman.0.1095484716.1588.mailman@wikinerds.org>, 1 failures


There is also a log file named "smtp-failure" with many entries like this one:



Sep 18 13:25:33 2004 (23519) delivery to info@wikinerds.org failed with code -1: (110, 'Connection timed
out')


There is also an "smtp" log file which has lines like this:



Sep 18 13:28:42 2004 (23519) <mailman.1.1095486181.13384.mailman@wikinerds.or g> smtp for 1 recips, compl
eted in 189.078 seconds


It seems like Mailman cannot access the SMTP server, or like the SMTP server can be accessed but refuses authorisation or something like that. According to my understanding, Mailman scripts work correctly, try to send email, and the SMTP connection times out after about 3 minutes. Since this is the first time I try to install Mailman, probably I configured something in the wrong way.

Can someone tell me what I need to do to make Mailman send mail successfully? Sorry for the long post, if I can get this problem fixed I promise you to write a detailed guide on mailman installation and post it on the forum :) :) :)

Thanks for reading this!
-- NSK

FZ
09-18-2004, 04:30 PM
Mine works fine with just 'domainname.com'.

The first thing that comes to mind is that you haven't started the Mailman processes:


/usr/local/mailman/bin/mailmanctl start

(in an SSH session, and assuming you have installed Mailman to that path). That fires up a few processes that need to be running continuously on your VPS for Mailman to function. Unfortunately, what that means is that if your WestHost server goes down (for maintenance, for example) that your mailing list functionality will halt until you login via SSH and restart the processes. Also, I think there are some e-mail aliases (commands) you need to add before you can work with it.

If the above is not the problem, it's possible that it just did not install properly. I would recommend checking out: http://www.domsch.com/westhost/ which explains exactly how to configure Mailman to work on our VPS.

Good luck.

nsc
09-19-2004, 12:04 AM
Thank you for your response.

Unfortunately I don't know what else to do. I have already started the Mailman process and added the email aliases. The Mailman lives in my ~ directory. I have consulted the website you linked and it helped me with the initial compilation/config but now it doesn't seem to relate to my present problem. My email works ok but Mailman still doesn't send email.

If I try the mailmanctl start command I get:



The master qrunner lock could not be acquired because it appears as if another
master qrunner is already running.


which means Mailman is running correctly according to my understanding.

When I installed Mailman I first used this:



SMTPHOST = 'mydomain.com'


but when I understood Mailman wasn't happy, I changed it to mail.wikinerds.org and then again to wikinerds.org - but Mailman still doesn't send email.

Except from asking for assistance from westhost/mailman users, I don't know what to do now :(

nsc
09-19-2004, 12:25 AM
I just solved the problem! :)

I used this:




SMTPHOST = 'my-ip-address'



and then I restarted the mailman process by using:




mailmanctl restart



by my-ip-address I mean the IP address (206.x.x.x) that correspond to my Westhost VPS.

Perhaps I should consult the Mailman FAQ (http://www.python.org/cgi-bin/faqw-mm.py?req=show&file=faq03.014.htp) earlier! :)

FZ
09-19-2004, 06:28 AM
Hmm, glad you got it working. 206.x.x.x? You must be on WestHost 1.0...? That's probably the reason for the config difference required.

nsc
09-19-2004, 07:34 AM
I am on westhost 2.0. I checked it with the tool I found from members.westhost.com and it says 2.0 and I also have the Site Manager 2.0 with https.

FZ
09-19-2004, 08:31 AM
Interesting. I thought 2.0 accounts were 69.36.xx.xx. Did you convert a 1.0 account to 2.0?

nsc
09-19-2004, 08:39 AM
Nope, I didn't convert 1.0 to 2.0. I got a Value plan on August 2004 and I was assigned this 206.x.y.z IP address from the beggining, and it was Westhost 2.0 with ssl.