View Full Version : authorized_keys not working

08-30-2004, 09:08 AM

I cannot seem to get SSH keyless authorization working in my 2.0 account. I have tried a bunch of different permissions on the different files and folders, but it always asks for a password. I have already read the very helpful suggestions in the "codeworks" "tips and tricks" page, but still cannot get it to work. Also it shouldn't be a problem with my client PC as my keys worked just fine with the 1.0 account.

Current paths and permissions are as follows:

/.ssh drwx------ (0700)
/.ssh/authorized_keys -rw------- (0600)

Are these correct? Any suggestions?

08-30-2004, 11:42 AM
Try 644 (-rw-r--r--) on the authorized_keys file...

08-30-2004, 11:48 AM
I just tried, but it didn't work either, it's still asking for the password. :cry:

08-30-2004, 11:57 AM
Well I think that leaves just two possibilities:

1. There is something wrong with your actual keys... Did you upload them in ASCII? Are you sure your SSH program is using the local key properly?

2. There was a problem with SSH keys a while back - they had been disabled on all servers for a while (apparent security concern). I pointed that out to WestHost (since I use keys myself), and they subsequently re-enabled it (took them a few days) on "all servers". Perhaps they "missed" your server - i.e. SSH keys might be disabled on your server (especially after some more maintenance that was done a few days back). If you double check your keys and they are fine, then you should send in a support request and see what they say.

08-30-2004, 12:09 PM
About 1), I don't think there's anything wrong with my local key and setup because it was working fine with my previous 1.0 account two weeks ago. I've been uploading the public key through SCP from a linux box so there should not be any problems with the transfer mode i believe.

As for 2), that is an interesting possibility, i will open a support ticket directly with them. I just wanted to double check in this forum to see if i was maybe missing something obvious.

Thanks for your help FZ!

08-30-2004, 12:14 PM
No problem. Just so you have permissions right, they should be:

/.ssh drwx------ (0700)
/.ssh/authorized_keys -rw-r--r-- (0644)

NOTE: you said you're using Linux. I'm using PuTTY on Windows XP - there could be differences here that are causing problems.

Keep me updated.

08-30-2004, 02:59 PM
Yep, those are the permissions I have.

Also, as a test, i just tried connecting from an XP box with Putty but i got the "Server refused our key" message, i guess it must be something in my server.

So i will now open a support ticket and keep you posted, thanks for your help!

08-30-2004, 03:17 PM
No problem. Yeah - at this point it looks like a problem with the server. Let me know how it works out.

09-02-2004, 02:11 PM
Just to let you know that this was solved by Westhost's Support staff, they told me it was a server level configuration that needed changing. It works perfectly now :)

09-02-2004, 02:30 PM
Great - glad you got it working.