View Full Version : Spamassassin suddenly stopped working

08-25-2004, 10:58 PM
Suddenly this evening Spamassassin completely stopped working. Messages don't even appear to be hitting spamassassin. I've not changed anything. Here is a header

Return-Path: <RDDRUANGLPL@bigfoot.com>
Received: from (agcwkrub@[])
by flightweb.agapedata.com (8.11.6/8.11.6) with SMTP id i7Q4tLl00671
for <sales@agapedata.com>; Wed, 25 Aug 2004 23:55:21 -0500
X-Message-Info: TFCFrZL04mDffIWZk18i6CD4DXTvdERe
Received: from nrdbgcp55.worldnet.att.net ([]) by kn9-k63.hotmail.com with Microsoft SMTPSVC(5.0.2195.6824);
Wed, 25 Aug 2004 23:54:15 -0600
Received: from breampleistocenephotolyticta01 (idaho[])
by worldnet.att.net (pxplvlj25) with SMTP
id <92178692176095351926drz1o>
(Authid: NoelOhara);
Thu, 26 Aug 2004 08:46:15 +0300
From: "Kitty Hoover" <RDDRUANGLPL@bigfoot.com>
To: "'Sales'" <sales@agapedata.com>
Subject: Be good
Date: Thu, 26 Aug 2004 08:53:15 +0300
Message-ID: <850545b3sx19$4t4l7006$46l9ywth@pointwiseaidacubcx 13>
MIME-Version: 1.0
Content-Type: multipart/alternative;

Any suggestions on what might have happened and how I can resolve it?


08-26-2004, 02:30 AM
How large was this e-mail (filesize)? If it is greater than 256KB, then SpamAssassin did not process it...

08-26-2004, 12:11 PM
It was a tiny test message. This problem is now affecting all our domains on the server. No messages regardless of size are getting scanned by spamassassin. It stopped suddenly at 8pm last night for no apparent reason. So far I haven't heard any replies from Westhost support. I'm desperate to get this fixed.

Here is my procmailrc ... bear in mind I've never changed this. It's the way it was set up by westhost originally so it's always worked but maybe it will offer a clue...


* ^List-Software: WestHost

* < 56000
| /usr/bin/spamc -f

* ^X-Spam-Level: \*\*\*\*\*\*\*\*\*\*

* ^Content-Type: MULTIPART/MIXED
*^Content-Disposition: (attachment|inline);

Here are the permissions on procmailrc

-rw-r--r-- 1 root root 393 Feb 18 2004 procmailrc

08-26-2004, 12:24 PM
Don't see any problems with that - except it is missing the actual send-to-SpamAssassin rule! Is this what is contained in your /etc/procmailrc? Are you using a .nospam anywhere?

08-26-2004, 12:27 PM
This is the actual procmailrc. Im not sure what the .nospam is?

08-26-2004, 03:14 PM
Don't worry about the .nospam

Having had a second look at the code, I realized that /usr/bin/spamc -f is the "send-to-SpamAssassin" rule I was talking about - I just didn't pick up on it because I have not seen WestHost use this method before - it has always been something like /spamassassin.

I tried to get into my Site Manager to try and install the version of SpamAssassin provided by WestHost (I am currently running a custom install on my own), but the darn thing popped up JavaScript errors (and the annoying "Please wait" screen would not go away - WestHost, please please please take that annoying thing away, it does more harm than good). When I get the chance, I'll try again - maybe WestHost has changed/upgraded SpamAssassin.

Anyone else have any ideas?

08-26-2004, 10:11 PM
Westhost upgraded my spamassassin to 2.64 and appears to have resolved the problem. Thanks for all your help Fayez!!

08-27-2004, 03:26 AM
Oh okay - glad you worked it out.