View Full Version : getting email trouble

07-20-2004, 06:04 AM
I have six domains at westhost.

Over the past week or so three of my accounts have had trouble with email.

Basically I get the password login screen as if my password is wrong even though I have not changed any passwords.

Here is the message I get in outlook express:

There was a problem logging onto your mail server. Your Password was rejected. Account: 'xyz mail', Server: 'mail.xyz.com', Protocol: POP3, Server Response: '-ERR [SYS/PERM] Unable to process From lines (envelopes) in /var/spool/mail/xyz; change recognition mode or check for corrupted mail drop.', Port: 110, Secure(SSL): No, Server Error: 0x800CCC90, Error Number: 0x800CCC92

Has anyone else had this problem?


07-20-2004, 10:53 AM
I got some info from westhost about this issue.

I am getting some email that is missing From info and this causes the email to hang up.

Once the offending email is deleted by support the rest come down okay.

I do not know how this happens but shouldn't "the system" be able to deal with this rather than locking up all email?


07-20-2004, 02:08 PM
It may be the same story as here:
http://codeworks.gnomedia.com/westhost/tips.php (2nd item)

where a download had been aborted, then removed, but the mail file became corrupted.

07-21-2004, 08:34 AM

Thanks for the reply.

Are you (your procedure) saying I could SSH into the mail file and fix the problem myself?


07-21-2004, 09:45 AM

Yes, you can take a look at the file while in a SSH shell. When the above incident happened, it was very clear that there was file corruption and I just removed the damaged bits with the editor.


07-21-2004, 11:05 AM
Thanks Jalal - Charlie

WestHost - MMellor
07-21-2004, 03:05 PM
Hello Charlie,

As far as deleting emails off your account here is another way to do it:

Go to Start and then Run,

type: telnet (account.com) 110 example: telnet bob.com 110

type: user bob@bob.com
type: pass (don't tell anyone)

type: list (this will give you a list of all your messages)

type retr (message number) example: retr 1 (this will allow you to view the message)

type: dele (message number) example: dele 1

If you have an email that is stuck on your account this is a great way to clear them out. If you have any questions on this please let me know.

07-21-2004, 03:22 PM

I'll try that - thanks for your help.


07-23-2004, 07:10 AM
I tried Mike's procedure but it did not work. I PM'd him several days ago but have not heard back.

When I type user abc@abc.com it crashes the telnet session.

Anyone have any thoughts why?


07-23-2004, 08:37 AM
Have no idea but the same thing happened to me when I tried it. I did end up logging in to the account I was trying to do it on via putty and then I tried I ran the telenet command and was able to get it to work. It was a bit buggy since if I did not type the user abc@abc.com quickly it still would disconnect me.

Oh once I got in I could not remember how to get out. Had to do a quick search on "pop3 commands" and found it.

type: QUIT

Most days my mind is on vacation. :)

07-23-2004, 09:20 AM

when you logged in via putty did you start with logging in SSH, then entering username and password, then when logged in enter: telnet?

when I tried that it accepted the telnet command but then said that user abc@abc.com was an invalid command.

*UPDATE* I made a mistake - I see what I did - I was able to log on like you


07-23-2004, 10:22 AM
Don't you have to type . . .

helo (domainname)
. . . before the user command, where domainname is the name of the computer that you are connecting from.

Check out section 3.5 of the rfc . . . http://www.faqs.org/rfcs/rfc821.html

I'm pretty sure this rfc is been superceded, but it's still valid. I just found it in section of this rfc, which looks to be the newest version.


07-23-2004, 11:37 AM
A corrupt mail drop happened to me too, today. I think it was due to a really slow connection to my account (I'm on dial-up) and my e-mail program gave up downloading mail. Incidentally, all the mail I downloaded during that session came through as garbage (no proper headers, etc.) in my e-mail program (but I can view source to see the body of each message, so that's fine). Next time I tried checking mail, it gave me the same "unable to process From lines" message - all I did then was log in (via SSH), and edit the /var/spool/mail/mailaccountname file to remove the garbage, and get the first From... line onto the first line in the file.