PDA

View Full Version : phpBB database problem



avila
07-15-2004, 02:43 AM
Hi,

The problem I'm having is this. Several members have signed on and
been shown in the forum information box as 'green' Moderators though
the user has never been set as a mod. We can change him back to
'blue' status only when we change another of our ACTUAL mods back
to 'blue' status.

Upon checking the database I found that it appears that a large selection
of users were assigned the same values as other members in their
personal usergroup value.

Example...


INSERT INTO `phpbb_user_group` VALUES (224, 224, 0);
INSERT INTO `phpbb_user_group` VALUES (225, 225, 0);
INSERT INTO `phpbb_user_group` VALUES (226, 226, 0);
INSERT INTO `phpbb_user_group` VALUES (227, 227, 0);
INSERT INTO `phpbb_user_group` VALUES (179, 237, 0);
INSERT INTO `phpbb_user_group` VALUES (180, 238, 0);
INSERT INTO `phpbb_user_group` VALUES (181, 239, 0);
INSERT INTO `phpbb_user_group` VALUES (182, 240, 0);
INSERT INTO `phpbb_user_group` VALUES (183, 241, 0);

...


As you can see, for some reason after user 227 we jump to user 237
and the usergroup jumps back down to 179 linking together in pairs
everyone between 179 and 283 or so.

This obviously causes issues with giving permissions to a second user
unintentionally when you give the "linked" member moderator permissions.
It also throws off the numbering then for the actual groups
which we use I believe.

So is there a way to fix the linking problem while at the same time keeping
the existing user groups memberships in tact?

This is important as we use private usergroups to quickly add and remove
moderators etc. In a potentially related event, we recently gave a member
mod group status but they have not turned 'green' eventhough they have
all moderator privilages. Could this be related to being "linked" to someone
who does NOT have moderator privilages?

I simply assumed that any permissions etc you gave one "linked" member
would appear for the other of the pair, but is it possible the "links" only
work in one direction and this is why the member can have mod privilages
but NOT be 'green'?

Thanks for any help you can give on this!

wildjokerdesign
07-15-2004, 06:10 AM
I jumped over to the phpBB forum to see if I could find anything and noticed that you had post there also which was going to be one of my suggestions. I have noticed this here on the WH forum one of the regular users shows up colored as a mod. I have not seen it on any of my boards but I have them modded out pretty heavy and they are all current up to 2.08... just noticed there is now a 2.09 looks like I have some work to do... It could be as they suggested over at the phpBB site that upgradeing can help although I don't think it well do anything to repair the problem in your database.

I'll keep looking to see if I find anything but most likely you'll get better feedback over at the phpBB site.

Armadillo
07-18-2004, 06:09 PM
Now phpBB is up to 2.0.10.
:shock:

wildjokerdesign
07-18-2004, 09:22 PM
Ahh.... man not again! :)

torrin
07-19-2004, 09:27 AM
Good thing I was lazy about updating. :P