PDA

View Full Version : need help setting up a webmail subdomain



fsuchucky3
06-24-2004, 06:16 PM
please help me set up a webmail subdomain...

ive searched and read the forums and tried alot of stuff...

basically, i have installed neomail, its at

http://domain.com/cgi-bin/plugins/neomail/neomail.pl

i want webmail.domain.com to be set up to direct to that.

in the domain management section of the manager, i have the subdomain webmail set to /var/www/html/cgi-bin/plugins/neomail

but... there is no index file in that directory, so i think thats gonna be a problem... i could put a php redirect from an index, but i'd rather have the subdomain go directly to neomail.pl

one thing i have noticed is that i don't seem to have an html/ directory in the /var/www/html/ like everyone else in the forum has...

thanks in advance!
chuck

<mark />
06-24-2004, 06:57 PM
One thing I've noticed is that there are quite a few symlinks. For example, I have a /var/www/html/ but the "www" symlink in / it points to /usr/local/apache (which doesn't have an "html" directory in it).

It may be missing, but you might just need to look around a little more to find it. Hope this helps.

wildjokerdesign
06-24-2004, 07:21 PM
This thread should give you the different options you can use.

http://forums.westhost.com/phpBB2/viewtopic.php?t=1476

It took me a bit to find it. Yes the search does not work that well. Just not very robust. Luckliy I knew the post was there and just kept at it. Had to search through quite a few neomail post. :)

You are going to want to point your subdomain someplace else other then where you have it now but that is explained in the thread.

Mark is right that there are alot of symlinks in the set up and it can get a bit confusing. Everyone has a /var/www/html/ directory it can just be a bit elusive at times.

Let us know if you need anymore help.

Shawn

fsuchucky3
06-24-2004, 08:30 PM
thanks guys, ill work on that...

though right now the NBA Draft has me enthralled!

chuck

fsuchucky3
06-24-2004, 09:08 PM
thanks shawn that htaccess solution worked perfectly.

also, i see the html directory. i was in a shell before, thats why i was going crazy!

chuck