PDA

View Full Version : my customized formmail wont work



firebirdfan
05-13-2004, 10:55 PM
I use this formmail on all the other vps that i'm having on WH, & it works fine. i've activated the ftp accounts for the emails which has an effect on processing the formmail.

All that has been done, but when i test the form - there's no mail comin through to my side, what possibly could be the problem.

All the settings are the same on the other vps.

wildjokerdesign
05-14-2004, 08:09 AM
No errors when you send the form? Check for a file something like dead.letter in your root directory. I have gotten that when I have had something off in the email settings. Hard to tell with out more info what could be wrong. What is the customization you did?

firebirdfan
05-16-2004, 08:07 PM
Yes, spot on Shawn, I see all the emails that failed to go through is stated in the dead letter, so how do i rectify this problem ?

wildjokerdesign
05-17-2004, 07:18 AM
The times that I have had the problem and found them in dead.letter is because I had messed up the email address I wanted to send them to. A typo and when I looked at the dead.letter I saw the mistake in the email addy. So look close at the email addy it tried to send to.

Is the email you are sending to on the account the script is on or on a different one? There was the one user that had problems sending from one VPS to anouther that had the same IP wich is why I ask. But I am not sure if that was internal or when they tried sending using an email client like Outlook.

firebirdfan
05-17-2004, 07:43 PM
It's currently sort of resolved , after setting a catch all address.
From this post
http://forums.westhost.com/phpBB2/viewtopic.php?t=1669&highlight=dead+letter

Had to wait a while for it to kick in, also did submit a ticket & tech said that it was due to some of my scripting error. But I've tested it on other vps, it's ok.
But I've got 1 last problem, why does it say insufficient permission for procmail ,where i included an email from the same vps but different domain..

wildjokerdesign
05-17-2004, 09:12 PM
The inssuficient permission thing used to come through on emails that where sent back to root. The fix on that was to ad it to your alias file and direct it to an email account but had to be done manually could not be done via site manager.
1. In /etc/aliases add the following line:
root:username

where username is the name of the user you want to send root messages to
2. From SSH, run the following command:
sendmail -bi


There was a user haveing problems sending from one VPS account to anouther that was using the same IP. WestHost gave a fix for that stateing to disable email on those two VPS accounts. I am not clear on that fix and I'll try to hunt down the thread that was in. I don't think they where talking about the individual email accounts but the email setting somewhere else... I think in Domain Management. At the time I asked if doing that would affect forms that sent from the web site and they said no.

I have a feeling your problem may be wrapped up in all this somehow. Like I said I'll try to hunt down the threads. Wish I could remember all this off the top of my head. :)

Found It:
http://forums.westhost.com/phpBB2/viewtopic.php?t=1885

It was down in resellers section and the last post in it is the fix WH gave the user.