PDA

View Full Version : Procmail and users



dpfaigin
04-14-2004, 03:59 PM
In my neverending question to move my site from my old provider to westhost, I find myself running into a question on procmail.

My current main user is "cahighways@cahighways.org", but all mail goes to "faigin@cahighways.org" (which is set up as an email only account). I had an extensive procmailrc on my old provider that did *lots* of spam filtering, in addition to spam assassin. Where would I install that procmailrc? There is no /pub/ftp/faigin (or is that /ftp/pub... in either case, neither is there), and putting it in /home/cahighways/ doesn't work.

Suggestions?

Daniel

wildjokerdesign
04-14-2004, 04:09 PM
Go to your Site Meter and set up/enable FTP Access for the user faigin. This well create the home directory for it where ever you specify. You can then go back and disable FTP Access for the account and the directory well still be left along with letting the system know it is there. You can then place your promailrc for that user in the directroy it you specified.

dpfaigin
04-14-2004, 04:20 PM
When I go to the site manager, Email/FTP pane, and click on the box to edit the account, the site manager hangs and I have to close the window.

Suggestions?

dpfaigin
04-14-2004, 04:43 PM
Update: Now site manager (and the procmailrc) is working.

dpfaigin
04-14-2004, 04:45 PM
So, now how do I get the procmail logging to work correctly. I'm seeing nothing in the procmail.log file. Is this a "cross account" problem?

wildjokerdesign
04-14-2004, 04:52 PM
I think Jalal's site tells how to turn on procmail logging. It also has some stuff on customizeing your shell that may answer the question you asked in your email to me.
http://codeworks.gnomedia.com/westhost/

I think most the files you may need to mess with are going to be in the /etc directory. On Jalal's site the procmail info is on the Email pages part one and two.

FZ
04-15-2004, 11:24 AM
/etc not /ect, Shawn :P

wildjokerdesign
04-15-2004, 01:27 PM
/etc not /ect, Shawn :P

**** I keep doing that. Thanks! :) Fixed it.