PDA

View Full Version : cannot disable catchall?



Frisky
04-03-2004, 04:13 AM
Okay, once more into the breech, dear friends!

After searching this forum (and others), I've come to the conclusion that only by disabling the "catchall" address am I going to be able to cut back the spam level (which came dangerously close to putting me over my bandwidth level last month, I might add!).

Problem: The site manager section for e-mail/ftp has a button that says "remove catchall alias". You get back a box asking if you truly want to do that (of course I do! That's why I clicked it), the page reloads and the catchall is still shown. Testing shows that the "catchall" is still active (and forwarding) invalid e-mail addresses.

So, my question is...Since my "catchall" is also the default (e.g. domain@domain.net), is there a simple way to delete the catchall function, while retaining the "default" functionality? I use the default address (I know, I know! My bad!) in too many places on my site to go without it being functional, but can no longer deal with that much spam taking up my precious bandwidth.

Any help will be gratefully appreciated!
Frisky

wildjokerdesign
04-03-2004, 06:58 AM
What you did in Site Manager should have worked. The only thing I can think is that perhaps there is something that well keep you from deleteing it if you do not have any othere email address accounts or aliases set up. Would that be the case here since you are using your default address? You could try adding an aliase or email account (that you could slowly switch over too) and see if that makes a difference. Even with catchall disabled you still recieve mail on the default domain@domain.com (wich is a bit irritateing since it seems some spammers realize that).

There are others things you can do with modifying files but that would be the easiest if you can get it to work.

FZ
04-03-2004, 08:27 AM
I think the default e-mail address (domain@domain.com) remains enabled no matter what you do. What you probably saw was that your catchall's destination was your default address. So, removing the catchall will NOT disable that account - in fact, it's extremely difficult to disable that account even if you want to.

To force removal of the catchall, you will need to edit the /etc/mail/virtusertable file. Before you start, make a backup of the original on the server. Look for:


@domain.com domain

And just remove that line. If you have more than one domain, you should remove the other entries too (which will look like "@domain2.com domain", and so on). Save the file (and if you are re-uploading via FTP, make sure to upload it in ASCII/text mode). Now, you need to log in via SSH and type the following (pressing enter after each line, of course):


cd /etc/mail/
makemap hash virtusertable < virtusertable

Then, to confirm that your catchall has been disabled, just log in to your Site Manager, and then go to the Aliases section in E-mail/FTP Management.

Frisky
04-03-2004, 10:41 AM
Well, I just tried your suggestion FZ, but it didn't work. The "catchall" continues to show up, along with the non-working button to delete the catchall. Kind of frustrating, really, since I probably would never have enabled the catchall, if I had known that Westhost did not provide for a (working) way to disable it as well.

Can anyone else suggest any way to disable the catchall?
Frisky

adpwl1
04-03-2004, 11:02 AM
Frisky, the catch all will continue to show up in the Manager section, but by modifing the file like FZ states, will change it on the back end.

I would do what FZ says and then try sending to a non-existing email address in your domain and see if it shows up any where. My guess is it won't

Another suggestions, and I don't know if this will help with the quota issue, I have created a user account called "junk_mail" and set my catch all to that, then disabled email access for "junk_mail user.

Frisky
04-03-2004, 11:24 AM
I think I got it to work! I'm not sure exactly how, but I've tried sending a few messages to random addresses at my domain.net and they're bouncing back as "user unknown". The valid ones I want to see e-mail from all seem to be making it through, so I'm going to stop fooling around with this for today.

As near as I can determing, FZ's suggestion was right on the money. I googled "virtusertable" and found lots of stuff saying that after the makemap hash command, almost all of them said to restart sendmail. I did so and now all seems to be working as I wanted it to.

Thanks for letting me pick your brains! Better than the genuine tech support!
Frisky

FZ
04-03-2004, 01:44 PM
Glad you got it working. It's just strange that it still appears in your Site Manager though. I had mine disabled, but when I saw your post, I enabled it, and then disabled it using my method... I then went back in to my SM and it had gone. I did not have to "restart Sendmail" like you say - how exactly did you restart it, by the way? ;) It's not a daemon/running constantly so you shouldn't have to restart it after config changes anyway...