PDA

View Full Version : Cannoy re-install MySQL



codehooligans
03-31-2004, 09:43 PM
Okay. I messed up. I was mucking around with my user table and somehow locked myself out of the MySQL database. I tried to use mysqladmin to reset the password for root with no luck.

So I decided to try and re-install MySQL. First went through and remove via Manager phpMyadmin and MySQL.

Now when I attempt to re-install I get an error

"MySQL startup timeout. Command add ValueApp failed."

And ideas?

Paul

wildjokerdesign
03-31-2004, 09:54 PM
Not sure what you mean when you say you locked yourself out but I had one table that when I looked at it in phpMyAdmin it showed as "in use" which kept me from running anything on that database. I was able to do a repair on the database and it fixed it.

Would that maybe be of some help? It may be to late since you have tried the unistall via Site Manager and I am not sure of the error you are getting on trying to re-install.

codehooligans
04-01-2004, 08:29 AM
I checked in /var/lib/mysql and there is now no database or table present. So I'm assuming the uninstall of MySQL deleted all. Just need to get MySQL re-installed.

Paul

FZ
04-01-2004, 01:49 PM
Just guessing here, but maybe the mySQL application is still running in the background? Log in via SSH and type psx to see if it is. If so, kill the process (kill -9 12345, where 12345 is the process ID), and try again. Two things come to mind here:

1. Either WestHost was having some trouble at the time when you last tried (that error message seems like it is saying there is a problem installing it in terms of the "installation files/source" - I think I have had that problem once or twice before and it was because WestHost was working on something).

2. It can't/hasn't uninstalled your previous version properly, so there is some conflict (e.g. a file exists already that it is trying to re-install).

I reckon you should go ahead and contact support if it isn't the running process problem, and you still cannot get it installed. Keep us updated.

codehooligans
04-01-2004, 04:20 PM
Alright. Figured this out. I had backed up and then deleted ll the database folders under '/var/lib/mysql'. After trying the suggestion from FZ I noted the mysqld was not running. As a final guess I then just deleted the entire folder '/var/lib/mysql'.

When I tried again the database install worked. There must be something in the install script that if the root database folder is present then it does not attempt to create the mysql system database.

Thanks to all he tried to help on this.

Paul